Amplifi HD -- entire network drops under wireless load


  • I have a huge, old house that currently has 6 Amplifi HD devices (1 setup as the main router next to the gigabit cable modem, 2 doing wired backhaul, and 3 mesh points). I have noticed that any time there is significant load on the wifi that all devices connecting to that SSID will drop. For instance, I have a fairly new laptop that has a great wireless card. If I download a game on Steam and let the bandwidth limit be uncapped, it will ramp up to several hundred Mbps and then rapidly taper off. Once it starts tapering off, the wifi performance of any device on the same SSID will drop off to nothing. Devices connected to a secondary SSID being broadcast from only the main router are seemingly unaffected, though that's anecdotal (my wife works in the office and uses that SSID, and she says she hasn't noticed the connectivity issues, but I haven't personally verified). Devices connected to secondary SSIDs broadcast from downstream devices will lose connectivity, as will the laptop. I have been able to replicate this behavior with a Netgear Nighthawk R6700 operating in bridge mode -- it works fine until it gets under load, then it will cause the same issues. Note that in this case the Nighthawk was connected to my desktop computer. The only common link appears to be that connectivity is only interrupted when the wifi throughput is high. If I connect directly to any of the devices over Ethernet, I can get fast throughput reliably without tanking the entire internet. Do I have a hardware issue? Do I need to adjust some settings? I'd really like to have reliable and fast wifi. I haven't been able to find anyone reporting this particular issue so aside from blindly changing settings and hoping for the best, there hasn't been much for me to try.

    My current settings:
    -Band steering is on
    -Router steering is off
    -2.4 GHz is on auto channel, 20/40 MHz bandwidth
    -5 GHz is on auto channel, 20 MHz bandwidth
    -Hardware NAT, UPnP, and IPv6 are enabled
    -IGMP Proxy is enabled
    -802.11k and v are enabled
    -802.11r and A-MSDU are disabled

    EDIT: Should also note that when all of the devices drop from the network, the router still reports the entire period as uptime -- so for instance even though this happened ~30 minutes ago, the Amplifi app still says that it's been up for over 12 days.


  • Hi @jdr2390845 - is there a particular reason you chose 20 MHz channels for the 5GHz band (i.e. needing more range or a noisy environment)?

    Have you tried 40 MHz channel widths to allow for higher potential throughput of the radios?

    If possible, you might consider taking the wireless mesh points offline and seeing if the problem manifests with just the wired backhaul routers

    Then bring the wireless mesh points back online one at a time to see if a particular node is causing the issue with its link

    If you do find a problematic wireless node, then try adjusting its location


  • @Derek-Saville Thanks, I will give these a try. I am using 20 MHz for the 5 GHz band because my house is large (~5,000 sq ft) and is old construction, mostly brick. I wanted to give those signals maximum potential to propagate, but I will try seeing if a wider bandwidth would alleviate the problem.


  • Hi jdr2390845 - for a difficult environment you might also consider manually separating the bands for as many clients as possible

    Unfortunately this is a PITA on HD's as you have to manually create the individual band SSID on each mesh point

    Just make sure the clients "forget" the main common SSID and only know the unique band SSID that you want them on

    At that point you can also consider disabling Band Steering, and unless you have a specific incompatible client, consider enabling and testing with A-MSDU on again

    5 GHz 802.11ac on a 20 MHz width channel is only 87Mbps (MCS8) per link and not that much more throughput than 2.4 GHz 802.11n 20 MHz at 72Mbps (MCS9) per link

    So depending on the environment and conditions, you may actually be getting better performance and range out of the 2.4 GHz anyways (versus 5 GHz @ 20 MHz width)

    If you stay with a 20 MHz channel width for 5 GHz you might then also play with setting the wireless mesh point backhaul radio to 2.4 GHz (or vice versa depending on the mix of clients and if you manually separate the bands) when you bring them back online


  • @Derek-Saville Just wanted to follow up on this. The 5 GHz bandwidth was definitely the problem. After switching from 20 MHz to 80 MHz, I have been unable to replicate the issue, even when simultaneously hammering my network with 2 machines doing large downloads simultaneously over the 5 GHz band, each of which had previously caused the issue in short order. Thank you for pointing that out! You've saved me a ton of headaches.


Log in to reply