AmpliFi Alien Firmware v3.6.0

  • @RuiPaulo I tried rebooting the Alien and the devices and 5ghz connection was still not happening for most. DFS not ready for prime time. Needs more work.

  • @Racerprose If you reboot the Amplifi, the same radar scanning thing kicks in and you have to wait again. Leave the Amplifi on with DFS on and then wait 1 minute. After that, try connecting your client to the Wi-Fi network.

  • @RuiPaulo Yeah, I know. Trust me, I gave it plenty of time. I even left my house to go run errands and when I returned with my iPhone 11 Pro. When I got home my phone was stuck on 2.4ghz.

  • I'm starting to see what @Racerprose is talking about, but in a slightly different fashion. I went out to the far reaches of where my signal extends to with my iPhone SE 2020, and it dropped to 2.4 GHz, then came back in and it stuck. Rebooted the phone, and it thinks it should be on WiFi 5, 2x2. I think it was doing this before the update however. It was registering as WiFi 6 again when I went and upped the WiFi 6 to 160 MHz, but when I upped the WiFi 5 to 160 MHz, it kicked the phone off WiFi 6. Thinking I'll change the WiFi 5 back to 80 MHz to see if it will let me on WiFi 6, it's not like anyone else in the house is noticing a difference...

  • Some helpful settings for some folks that seem to work well for me.

    When you are connecting on WiFi -- what speed do you see on the client (such as laptop?) You can see this here for example on a Windows 10 machine.


    I run configuration as follows; see if your settings are similar?
    App Interface Settings;
    Band Steering = On
    Advanced Settings;
    2.4 Ghz WiFi 6
    Bandwidth 20Mhz
    5Ghz WiFi 6
    Bandwidth 160Mhz
    Bandwidth 80Mhz

    WiFi AP Names


    Additional 5Ghz Radio ENABLED

    5GHz Wi-Fi 6 ENABLED
    2.4GHz Wi-Fi 6 ENABLED


  • @Racerprose Actually your case is referring to the band steering issue under the region of Canada. Try to set the country option on app to the United States to see if this solves the problem. I had the same difficulty as yours but it is solved by the means taken above.

  • @unseenone Notice any difference going from 3.6.0rc5 to 3.6.0 stable.
    It appears to be a different firmware which is not as stable as rc5 and more finicky for iOS devices, (getting stuck on 2.4Ghz).
    I ran some trials on rc5 (160Mhz) and saw WiFi 6 link speeds increase tp 1441/1225 on the same Intel card you show and on a new Surface Pro getting 2401/2401. Speeds approached 500/600 on a 1G network.
    This all came undone with 3.6.0 stable version. WiFi link speeds dropped to report in Kbps from Mbps. The DFS in auto has switched multiple times in one day from Auto 100 to 104 to 116 ... during the last month it never changed from channel 100. I switched back to 80 Mhz and still same. I'll likely do cold reboot.
    Of interest, in advance of having any issues support sent instructions for unique firmware downloads for router and mesh units to capture any problems (dropped devices or weak signals). I'll have to pull a support log after reinstalling the firmware as requested.

  • @jbenja6460 Watching with Keen interest. I also noted and documented significant speed hits (on WiFi) since the last couple of releases. Hopefully they will get it polished up. I think overall, it has been positive for most users, but clearly there are some speed drops and DFS issues. Historically, they have been good about looking at issues and fixing problems. Clearly here, and the dateline you can see all the various Release Candidates and releases. In the interest of full transparency and fairness. I did power cycle, and reran tests and got a bit of improvement (and what I find acceptable) performance. I have posted an updated chart.


    Furthermore, all these were on WiFi 6. I believe the DFS needs to polish.

  • Mine is now configured similar to @unseenone , I finally enabled IPv6 and have:
    2.4 Ghz WiFi 6 set to Auto, but at 40 Mhz
    5 Ghz WiFi 6 at Auto and 160 Mhz
    5 Ghz WiFi 5 returned to Auto and 80 Mhz
    My sole WiFi 6 item (for the time being), the 2020 iPhone SE is displaying as WiFi 6 again. However it is displaying MIMO as 2x2. Shouldn't that be 4x4 or 8x8? Speed is still OK, but it seems some items that should be WiFi 5 are showing as WiFi 4 and are now working on the 2.4 Ghz band

  • @metalbender Some possible tweaking or checking that the client is capable, and 160 is configured may be needed. 2x2 MIMO is all most clients are capable of (Including my own).

    Seeing as you have a similar card, take a look at the settings. I'm on Auto (bandwidth), Highest Power, and auto for channel width on 2.4 and 5. If you note, the LAN WIFI Properties say 160 on it.


  • @metalbender We never had any problems with my wife's 2020 iPhone SE on WiFi 6. Although, it always has slower speeds up/down than my iPhone XS regardless of 80 or 160 Mhz. Like today my XS is 500/550 and SE2 is 400/450 on a 1G network.
    I believe the antenna's are set-up so phone is 4x4 for cellular and 2x2 for Wifi.
    Since little benefit to run 160 Mhz for me, I opted for range and kept at 80 Mhz, (no meaningful speed difference on either phone). Our new Microsoft Surface Pro does benefit using 160 Mhz, but we use it for travel / work.

  • @ileonhsiao This did not fix anything for me. DFS and band steering has issues no matter what. Feature should be listed as BETA.

  • @Racerprose You do need to let it run for what seems like a few hours to do it's thing. Give it a shot, and using the 160 if it works, for me has proven better due to hundreds of AP's around me presently. I have no interference or degradation, which is typical on those bands.

  • @metalbender Just ignore them, and let's see if they eventually connect over. I'm guessing they will eventually. Some devices also have the ability to set a preference for bands. Worth looking at it.

  • Anyone having horrible choppy video calls, mainly FaceTime?

  • Is anyone else having issues with a mesh point defaulting to 2.4Ghz backbone whenever you make a wireless change? I am having to reboot my meshpoint in order for it to use the 5Ghz backbone. And it takes forever compared to the previous fw's to come back online.

  • Hi @cmdshft - do you have Automatic Backbone Band Switching enabled or disabled in the Web UI?

    And it takes forever compared to the previous fw's to come back online.

    Are you using a DFS channel?
    By regulation all access points using a DFS channel must scan and confirm a channel is clear before beginning to use them
    This can take quite a while and if interference is detected you can be knocked off the channel for quite a while as well
    This scanning will take place continuously, and since the Alien does not have a dedicated scanning radio, the process needs to be blended in with normal wireless client and backhaul communication

    DFS can drop the wireless range of a mesh point considerably due to the lower available transmit power requirements, so you may need to move the mesh point closer to the main router for an equivalent non-DFS link

    If you are constantly being dropped to 2.4GHz (non-DFS) either the DFS interference scan is taking too long (this can probably be improved by AmpliFi), interference is being detected (possibly falsely) and the channel has been manually fixed so the only option for the router is to fall back to the 2.4GHz band, or the SNR is dropping below a threshold at the current placement location and the Alien is determining a better or more stable link can be maintained on 2.4GHz

    And if you have multiple mesh points then any one of them can force the entire mesh onto 2.4GHz (or another available channel) for any of those reasons

  • New issue with the HomePod mini and band steering

    so with 3.5.2 didn't have this issue

    with 3.6.0 it started

    So 2 homepods are connected via a stereo pair for some reason the music was not syncing. I would turn off music and one one speaker it would stop on the other it would continue for awhile longer and then stop

    so I wasn't sure what was wrong and decided to split up both into 2 individual homepods

    Then I realised one was refusing to connect to 5ghz and stayed on 2.4ghz but the lease timing was always 0sec

    Rebooting them didn't fix it. Rebooting the router would allow both to connect to 5ghz and then moments later one would be on 2.4ghz again with lease time 0.

    So then I turn off band steering, broke up the SSIDs and use the common SSID name for the 5ghz so all devices would just re-connect.

    Both homepods went onto 5ghz, signal strength on both 95%. No issues with lease timing

    Re-paired them as stereo output and smooth since them

    Theres a lot broken with 3.6.0

  • @Gary-Sing HomePods don't fare well with common SSID names in my testing. I reserve the Wifi 6 5Ghz band just for my Apple devices (8 HomePods included).

Log in to reply