VMware Fusion Bridge Mode/ARP Issues


  • Since upgrading to v3.6.0, I've had an issue using bridge mode on any of my Virtual Machines running in VMware Fusion 12.1.2 (Mac). It's a very similar issue that was addressed here in this post:

    No Networking for Virtual Machines in Bridge Mode

    My issue is a little different in that I do get an IP address from the Alien router. And, for a VERY small amount of time, I can pass only a few packets of traffic. But it almost immediately times out. As soon as I change it to NAT/shared mode, everything works fine.

    I was also able to reproduce this problem on more than one Mac device, using different version of Fusion. I've also tried different OS releases (Windows 10, Server 2019 and CentOS).

    If there are any logs or packet traces I can provide, please let me know.

    Thanks for your help!


  • Some more details on this issue...

    Hardwired my Mac using Ethernet directly to the Alien. VMs running in Fusion worked just fine using bridge mode. It's good to note that these same VMs also show up in the Devices & Topology pages on both the Mobile App and Web GUI. They never show up when bridging over WiFi.

    When I do a WireShark and release/renew the IP address, I successfully obtain one. DHCP packets acknowledge this. However, when looking at the same trace for ARP packets, I see something peculiar. The trace seems to indicate that the Alien thinks that my Mac has the IP address that was assigned to the VM. I

    [Duplicate IP address detected for 192.168.25.219 (MACaddr of my Mac) - also in use by (MACaddr of my VM) (frame 417)]
        [Frame showing earlier use of IP address: 417]
            [Expert Info (Warning/Sequence): Duplicate IP address configured (192.168.25.219)]
                [Duplicate IP address configured (192.168.25.219)]
                [Severity level: Warning]
                [Group: Sequence]
        [Seconds since earlier frame seen: 83]
    

    Alien (.1) <--> Mac (.227) <--> VM (.219)


  • Seems this was just fixed the latest beta release, 3.6.1 rc4. At least I'm not experiencing it anymore!


Log in to reply