iPhone WiFi Private Address

  • I've been having an issue with my iPhones connecting to WiFi, typically after I reboot my Alien (v3.6.0). The iPhone just refuses to connect until I disable the "Private Address" feature on the iPhone. I've tried toggling this feature on/off after several minutes, hours and even days. Also tried hard rebooting the phone several times.

    Anyone else experiencing this issue? And suggestions on how to resolve it. Thanks in advance!


  • @kscurloc Hello, could please let us know which iOS version and iPhone model you are using?

  • Sure...

    iPhone X 14.7.1
    iPhone 12 Pro Max 14.7.1

  • I also have the problem. On my iPhone and 2 iPads in our family do experience it. However one remaining iPhone does not, and it has the setting turned on..

    iPhone 8 Max running 14.7 (this is the latest update for iPhone 😎
    iPad Pro's (Gen 2) running 14.7.1

    iPhone 8 running 14.7
    iPhone SE running 14.7.1

    Interestingly, my phone initially did not have any issues. One of the iPad's we have experienced it and I did a "forget network" and could not ever get it to connect. About a week later my phone in the middle of the day, even though it had not updated, disconnected from wifi. then it also would no longer connect. I noticed the "private addressing" option and turned it off. It then connected right away. If you turn it back on, then it no longer can connect.

    So whenever a device no longer connects I turn that feature off and then it connects. So far 3 devices. Only have a couple more to go, but it is annoying.

  • Seems this was just fixed the latest beta release, 3.6.1 rc4. At least I'm not experiencing it anymore!

  • @UI-AmpliFi I have the same issue. I will not able to join my network after a couple of weeks and iOS tells that the password is incorrect. Forgetting the network and joining back will help to fix that issue temporary. Could you please fix it?

    Firmware: 3.6.2
    iOS: 15.1.1
    Device: iPhone 12 Pro Max

  • @mdreizin if you are still experiencing this issue with 3.6.2 please reach out to Apple support.

  • @UI-AmpliFi could you please provide more details? I have not had that issue prior updating to 3.6.2 and I believe Apple does not cause that issue.

  • I can confirm this issue exists with Ameplifi Alien. tried Samsung Note 20 Ultra, iPhone 12, iPhone 13 Pro, and iPhone 8. All have the same issue. Very slow wifi speeds when the private address is enabled. I get around 800-900 on WIFI 6 without private address enabled and close to 100 MB with the private address enabled. I need to enable this in my Windows laptop to see if there are any issues, right now it is disabled. I do not have another WIFI router to test this but I might get one and return it. So far all good as long as private address or random MAC address is not enabled. Amplifi Alien with firmware 3.6.2 With private address enabled works normally for a limited period of time, like a couple of hours if even that.

  • 0_1638554977356_870A2EEB-AE9D-491F-8038-D58A1D6A5464.jpeg

    that my issue

  • @Ahmad-Obaid-Ahmad-Alkendi-Almansoori Hi. The Privacy Warning is shown when the Internet service provider is filtering and blocking some of the traffic. If you search more about this topic you will find that many other Apple users experience the same warning regardless of the Wi-Fi router they are using.

  • @UI-AmpliFi
    For info, this recent post on Apple’s forums suggests if you see this error, you need a router that offers a more secure protocol, eg WPA3, which Alien doesn’t currently support.


    Encryption is the Culprit:
    You are getting this prompt because your router is using an insecure protocol (i.e. WPA2, which is no longer secure). So, either reconfigure your router's settings to be using a more secure one (i.e. WPA3), or upgrade to a new router that supports one. Older devices may not support WPA3. So, it would have to have WPA2/WPA3 open for use. Without getting too technical here, look at the user guide of your router, for more on configuring this.

  • @JamesLondon That user is confusing the error messages. They’re thinking it’s the “Weak Security” message that iOS will display under a Wi-Fi SSID if it’s using an outdated authentication/encryption standard. WPA2 AES is still considered secure in iOS and will not prompt a warning.

    The Privacy Warning about DNS traffic isn’t related to your wireless network encryption.

Log in to reply