iPhone WiFi Private Address

  • I've been having an issue with my iPhones connecting to WiFi, typically after I reboot my Alien (v3.6.0). The iPhone just refuses to connect until I disable the "Private Address" feature on the iPhone. I've tried toggling this feature on/off after several minutes, hours and even days. Also tried hard rebooting the phone several times.

    Anyone else experiencing this issue? And suggestions on how to resolve it. Thanks in advance!


  • @kscurloc Hello, could please let us know which iOS version and iPhone model you are using?

  • Sure...

    iPhone X 14.7.1
    iPhone 12 Pro Max 14.7.1

  • I also have the problem. On my iPhone and 2 iPads in our family do experience it. However one remaining iPhone does not, and it has the setting turned on..

    iPhone 8 Max running 14.7 (this is the latest update for iPhone 😎
    iPad Pro's (Gen 2) running 14.7.1

    iPhone 8 running 14.7
    iPhone SE running 14.7.1

    Interestingly, my phone initially did not have any issues. One of the iPad's we have experienced it and I did a "forget network" and could not ever get it to connect. About a week later my phone in the middle of the day, even though it had not updated, disconnected from wifi. then it also would no longer connect. I noticed the "private addressing" option and turned it off. It then connected right away. If you turn it back on, then it no longer can connect.

    So whenever a device no longer connects I turn that feature off and then it connects. So far 3 devices. Only have a couple more to go, but it is annoying.

  • Seems this was just fixed the latest beta release, 3.6.1 rc4. At least I'm not experiencing it anymore!

Log in to reply