AmpliFi Alien Firmware v3.6.1


  • @habbasi

    Definitely doesn’t help explain those. Really hope you are able to resolve those!


  • @habbasi The homeland mini is a wifi 4 device and not a wifi 5 device.

    The other devices are falling to wifi 5 because of wireless interference from the homepods. I have the exact same issue where if I place an iPad or iPhone near the homepods they drop down. Remove the homepods and they will more than likely not drop from wifi 6 to 5.

    However why the AmpliFi Alien doesn't push devices back up to wifi 6 when out of interference is a problem.


  • Do Apple clients attempt direct connections over WiFi with HomePods, which are not compatible with WiFi 6's OFDMA?

    So an Apple client switching to WiFi 5 in the presence of an Apple WiFi 5 only client media device seems more like intentional behavior than interference

    Clients also make the connection decisions, and AP's can only influence choice with various forms of delayed acknowledgments and other proprietary methods

    Not moving back to WiFi 6 seems like similar Apple client behavior when one would switch to 1xMIMO in power saving mode and fail to move back to 2xMIMO, so not surprising

    It's a cat & mouse game between AP firmware and Client firmware, and AmpliFi has been historically slower to learn and implement the tricks of manipulating clients - i.e. PS4 and Apple

    The disconnect issues could easily be some form of aggressive steering that Apple clients do not take well to and fail to reconnect, especially it seems over mesh points where there is another level of complexity

    It probably doesn't help that AmpliFi does not use Qualcomm reference designs and there are major differences between the NA and EN model implementations, which would probably be better off with independent firmware development, beta testing and releases


  • All of that makes sense but there’s little way to verify it. In addition… 47% signal in a room next to an Alien away from metal objects sounds… Not good.


  • @UI-AmpliFi Question — I have an Alien router with two Aliens hardwired as mesh units. I selected DFS on the Web UI, and I noticed one day that radar was interfering with one of the mesh units but not the main router. Usually, when radar appears on the main router, I simply go to “Wireless” tab on the app, go to “Advanced” and deselect “Auto”, change the channel, save, and then repeat the process to go back to “Auto” channel selection. This resolves the radar issue on the main router and allows it to use DFS again.
    But, when radar shows up on a mesh unit, I see no way of changing the mesh unit’s channel to “reboot” DFS. Seems I can’t do this on the app or the web UI. So is there a way to configure a particular mesh unit’s channel? Or do I need to completely reboot the mesh unit to re-activate DFS (as I did over the weekend)?
    Not sure why I can control the channel of the main router and not able to control the channel of a hardwired mesh unit.
    Thanks!


  • @Daniel-Osers an 'interesting' add on. After battling with this again for days (DNS issues) I turned hardware acceleration OFF again (I had it on since the 3.6.1 upgrade). .v and .k still on, DFS too (no .r). It's been 3 days now without issues for me.
    It would really help to understand what hardware acceleration really does - as in my case it may have negatively affected operation.
    FYI, 3 Alien Routers, 100% wired backhaul, Gig fiber connection.


  • Following up from my previous post - it's been 5 days or so since I enabled DFS, 802.11k and 802.11v. Connectivity is much improved, however there have still been a few drops here and there.


  • After about 7 days I started experiencing a bit of issue with the homepods mini reporting connectivity issues with the alien. Had to reboot the alien to get it to work.

    So it clearly not entirely fixed but definitely not as bad as previous versions.

    I don't know why the mini's are so finicky


  • I have just niticed a new issue. By iPhone 12 Pro Max (WiFi 6) gets knocked down to and sticks to 2.4 GHz unless it’s in the very same room as an Alien.


  • @Derek-Saville Hey Derek. So been testing quite a bit. When I handover music to HomePod, no drop to wifi 5. When I airplay to HomePod, no drop to wifi 5. I can't re-create the drop to wifi 5 so I can't troubleshoot that way.

    But

    When the phone does drop to wifi 5 and I leave my home (go out of range) and come back the phone does not go back to wifi 6 it stays on wifi 5

    If I reboot the router, the phone goes back to wifi 6.

    If I turn off wifi, the phone goes back to wifi 6


  • @habbasi I would turn off band steering and seperate the SSIDs and connect only to the 5ghz.

    Without the homepods band steering works well. With the homepods, band steering has never worked well


  • Yup HomePod mini still having an issue

    So I rebooted the minis and its giving a can't connect to wifi error. Second and sometimes 3rd reboot of the mini and it works.

    This is on the latest homepodOS 15.0

    So very unpredictable

    No issues with the larger homepods.

    If this is really a European alien issue and is hardware related then I think something needs to be said about it.


  • @Gary-Sing thank you for your input. We are working with multiple clients right now who have reported issues with HomePod mini. For now, it seems that there are particular HomePod mini revisions that are affected.
    We will provide a potential fix in the upcoming beta version.


  • @Gary-Sing I have the same issue as you seen in other threads. According to support it seems to be an identified issue. Hopefully the next fix actually works. I guess I am a little more lucky because my mini only gets disconnected every ~15 days.

    Note I only have one Alien and split SSIDs. All Apple devices are on the Wifi 6 5ghz band.


  • @UI-AmpliFi good news 🙂 hopefully the beta is out soon. Any idea why apple devices aren't moving back up to wifi 6 until the router is rebooted though?


  • @Gary-Sing Somehow, My Apple devices do go up to WiFi 6 now.

    I have the following settings:

    • No DFS, no 160 MHz, no Hw accel
    • 802.11 .k, .v
    • IGMP Proxy
    • (New, with your suggestion) router steering on, band steering off

  • @habbasi yes they will go onto wifi 6. but when they drop to wifi 5 for whatever reason they won't move back up. Only way to get it back up is to reboot the router or manually turn wifi off and then back on the device


  • @Gary-Sing Mine go back up automatically after I haven't interacted with the HomePods for a while.


  • @habbasi ok maybe I should turn 802.11 .k, .v on then lol. I have none of them turned on cause it should only affect mesh units


  • Little different scenario: I don't have the Wifi 5 radio on, but just the Wifi 6 (on 3 Alien Routers, wired backhaul). Generally speaking, no problem with any of the Apple devices - including multiple AX devices (M1 MacBooks, iPhone 13 Pro and 12 Pro) and the rest - Homepods and Home Mini - work fine on 5Ghz (none of those are AX devices). Almost all my devices are on 5Ghz steadily (that are 5Ghz).
    I do see my iPhone Pro 13 jumping to 2.4 Ghz quite often when not that far away from the router.
    DFS on, 80 Mhz, HW access off (having it on caused problems in name resolution for me literally making browsing impossible after a few days), .k and .v, IGMP Proxy. band steering on (single SSID), router steering off. Gig Fiber connection.


Log in to reply