Specific Sites and Downloads Blocked or Timeout


  • I’m not sure if anyone else has noticed this, but if you use IE 11 or Edge while connected to this router, it seems to cause a lot of website blocks and timeouts (while on a PC and on WIFI). A good example is if you visit Dell.com, click on products, click on laptops and then for home or for business. There are many other times where you can’t visit Dell.com at all. I have examples of other sites where the same thing occurs. On some, you can get the site but cannot download.

    A bit of my troubleshooting:

    1. Confirmed router is on current firmware.
    2. Separated my SSIDs with all other defaults.
    3. Reset the router and re-setup.
    4. Completely reimagined the PC and reinstalled with all current drivers and windows updates (Windows 10 Fall Creator).
    5. Tried the PC on a WiFi hotspot which resulted in success.

    Things I couldn’t try:

    1. LAN due to no LAN port on PC
    2. A different PC.

    I have nothing special in my setup suffice to say that I have a basic netgear modem usded to feed this router. The modem has some pretty basic LAN routing on it, and I have left it in DHCP and also bridged it. Neither makes a difference.

    By the way, if anyone is having troubles with cloud cameras and this router, your not alone. If you let this router perform PPPoE authentication for your DLS Broadband, it seems to block remote connectivity to cloud cameras. If you use the router in any other mode like DHCP or static or bridge, it will work for remote viewing of cloud cameras.


  • You might consider picking up a USB ethernet adapter (they're pretty inexpensive) and bypass your router, or even your modem depending on what type of service you have. I've been having similar issues, but after taking the router out of the loop, it doesn't improve so it's upstream on the ISP. You'd want to do something similar to try and rule that in/out.

    I'd also suggest setting your DNS settings to openDNS (208.67.222.222, 208.67.220.220) or googleDNS (8.8.8.8, 8.8.4.4) and see if that helps. Many times, hanging can be DNS lookup related. I'd recommend setting on your PC and not the router incase the problem is actually the router forwarder.


  • Both very good suggestions. I already bypassed both modem and router with a wifi cellular hot spot. So I’ve ruled out the PC being the problem and also the site being accessible as it should be. I have also tried googles DNS. The ping is worse than my ISP, but it didn’t resolve it either. That leaves two variables. Either the ISP or the router. I have a spare router and if swapping that resolves, then we’re back to the router. In the meantime, I have tested on both 2.4 and 5.2 and it’s still the same result. I’ve also tried setting the channels of the router. I think I’m going to find that it really is the router.


  • @michael-eckhoff

    Unfortunately I was able to confirm my suspicion. I borrowed a computer with a LAN port and connected it directly to the modem. I was able to visit the affected sites and download from them. I then swapped the Amplifi router for a known working router and modem combo from netgear. And it worked as expected to and I was able to visit and down from the affected sites. At this point I have elimited the ISP and their DNS. I have eliminated the computer as well. It is the Amplifi router causing website timeout and blocked download issues. I know it is a block on downloads because I’m getting a 403 forbidden when I’m not supposed to. There is definitely something wrong with the DNS handling or other with this router.


  • I have some interesting news. This does not happen on the guest network. Firmware 2.2.2 was also tried and same issue. They’re submitting the issue to engineering to work on it.


  • @gabe-z Very interesting! Thanks for posting and digging deeper. One thing you might want to consider as well is dumping your DNS cache when that happens. On windows, that's "ipconfig /displaydns". It'll dump everything your resolver has asked for recently (within the time to live period). I'm curious if the name of the sites you're getting 403's from points someplace other than it's supposed to (like to the router itself).

    When you tested the other DNS settings, did you test them on your machine, or did you plug them into the router's alternate DNS settings? If the latter, plug them into your machine settings so it overrides your routers DNS altogether and see what happens...


  • @michael-eckhoff

    Hello Mike. Really good suggestions. Looking at relays should have been one the steps. I flushed them out and started to visit the dell site. Unfortunately, it didn’t even record anything. However, it still got the timeout. Although I wasnt able to test the other site for the 403 just yet, it looks like it’s not even resolving. When setting to google DNS, it was set staticly on the PC and then verified with ipconfig. I’ve also tested up to 3 PCs at this point. I’m at a loss except to say that something, possibly DNS handling in the router, is really off. If it helps, I do notice some occasional sluggishness before a website loads. When I monitor the resources of the PC, I don’t see packet loss. I also shut off IPV6.

    Additional testing:

    1. I tried a usb wlan adapter with same result.
    2. I connected directly into the lan port of the router and it did work.

    Current thoughts are that LAN is ok, Wireless Guest is ok, and wireless main on 2.4 or 5 has some sort of DNS handling issue. This has been tried with and without SSID separation and also with and without mesh points.


  • @gabe-z Very interesting. I may have to spin up my Guest Wifi and see how things feel for a while.

    How handy are you with a network sniffer? Since you have a reproducible scenario (mine is fairly random), it may be worth your while to load up wireshark and see what's really going on. If you've never used one, i'm happy to talk you through it. If you have, filter down on dns and see if you can see the queries go out and not get a response. Of course, even then, you won't necessarily know where it's getting dropped unless you can do the same thing on the router side (which you can't to my knowledge).


  • @michael-eckhoff

    Hi Mike,
    I haven’t used wireshark in quite some time. I loaded it up and traced it a bit. I see duplicates and retransmits (several retransmits) when I play around with dell.com. I also see “out of order” and “who is” like clock work as it refers back to my notebook from the router. It’s really strange to me, as I wouldn’t think ARP would forget its cached MAC each time I visit the site, but yet it does. If ARP is normal in this regard (abnormal to me), then it looks like some serious packet loss otherwise. The same patterns exist on guest, but less so. With a new found suspicion, I created a static lease on the notebook. However, it didn’t change the result. I’m wondering if this ties into what others are reporting about 20 second drops.


  • Updated to firmware 2.6.0 and same issue.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.