Wifi disconnects since upgrading to 3.6.1


  • Ever since I upgraded my Alien routers (I have three, two of them in bridge mode), I have been experiencing random wifi disconnects on my iPhone 12 Pro. I have no idea where/how to begin diagnosing this issue.

    I have tried resetting my network settings on my iPhone, but that has not resolved the issue.

    Anyone else experiencing this issue?


  • I'm also getting constant connect/disconnects on my Apple TV, iPhone and Laptop with 3.6.1.

    After reporting the issue to support I've now downgraded back to 3.6.0 and the situation now seems better.


  • Same. Constant wifi disconnects with several iPhones and iPads with different iOS. Started after updating 2 Aliens to 3.6.1. In iOS settings, it will connect to the Alien but then rapidly display "No Internet Connection" and disconnect. Looks like Aliens can't downgrade back to 3.6.0 which worked. Laptops do not disconnect here.


  • Thanks for the posts. While it is sad to see others having this issue, it reaffirms that their may be a bigger issue present.

    To add to my original post, something I have noticed as well is that on many occasions my iOS device will not auto join my network even though it’s in range. I have to manually request to join. And on one occasion my phone said the password was incorrect when it attempted to join even though it had previously successfully joined.

    I have hard reboot my phone and the router, and reset my network settings on the phone. Nothing has improved.

    None of these issues existed prior to upgrading to 3.6.1


  • i downgraded back to 3.5.2 because my work macbook (12 inch retina) get's a DNS error on Wifi with 3.6.0 and 3.6.1 when 802.11r is enabled in the webui (portal), so yeah.. it's a mean bug, my iphone 12 pro had also that connection problem on 3.6.X and the problem doesn't show up on 3.5.2 😉


  • Same - I'm also getting connect/disconnects with AppleTV, iPhone and MBP with 3.6.1.


  • @Jeff-Talento Hi, please send us in a direct message your support ticket number.


  • How does one downgrade the firmware on the Alien hardware? The support article related to this process states that it's not available for the Alien.

    Since I last posted my Wife informed me that her Macbook Air is experiencing wifi disconnects.


  • Hi @anilnatha - you can download previous firmware releases here for manual installation…

    https://community.amplifi.com/topic/4557/amplifi-alien-previous-stable-firmware-versions


  • Same experience here.

    All iPhones (now on IOS15) with 3.6.1 suffering continual disconnects from 4 x mesh Aliens. I’ve just downgraded to 3.6.0 to see if it fixes it.


  • I have the same issues of dropping out of wifi connection for iOS, MacOS + one window 10 laptop.
    All have latest update installed.
    The ability to rollback to 3.6.0 with its simplicity is really awesome.
    Now after rollback for a week without any incidents.
    Thanks.


  • As a Net Admin for decades, and Systems Admin, and Wireless admin I can tell you Apple devices are a pita. It is a running joke just how bad they are to deal with from everything out there be it Cisco, Meru, Aruba etc. They tend to follow their own path with their drivers and not industry standard and then it falls on companies like in this case Amplifi to find a work around. Once the work around is found Apple releases another update and breaks eveything again. It's a constant circle with Apple devices, especially in the corporate/enterprise world. I was in a room once with a dozen top engineers for wireless, Cisco, HP, and I brought up Apple, to say the conversation got heated was an understatement. But Apple's "just work" right lol.


  • Last weekend I reverted the firmware to 3.6.0 on all three of my Amplifi Alien units and haven't experienced any WIFI disconnects since then. It's evident to me that something in the 3.6.1 firmware is causing this issue.


  • Same here, iOS devices keep disconnecting, other devices seem unaffected. Reboot of the router and mesh point seems to resolve the issue for short periods of time.


  • @skeeter906 we have release 3.6.2 version with gradual updates, that contains a fix for Apple devices, you can either wait for the 100% rollout or use Beta version - https://community.amplifi.com/topic/4978/alien-firmware-3-6-2rc1/29
    Thank you!


  • Hello, I still have the issue with 3.6.2.
    My ipad and my Windows 11 laptop are randomly disconnected.
    And if I can't browse http://amplifi.lan/ to downgrade manually...not responding...


  • @Nicolas-Deloyer Hi, Nicolas. Please reach out to our support team by submitting a ticket and attaching a support file right after the issue.


Log in to reply