Primary DNS Server setting not respected/working?

  • I have two Amplifi HD units with one acting as mesh point. I also use pi-hole on a server in the LAN and use that as primary DNS server by setting it up in the Amplifi app. After latest upgrade to 3.6.1 my devices seem to be getting the Amplifi router as the DNS server and not the configured primary DNS server. I have tried rebooting the router, rebooting the devices, releasing and renewing the DNS leases but it seems to not make any difference. Can we please confirm if this is a bug in the latest firmware?

  • @Ramkumar-Natarajan I've noticed this too. Very frustrating and has broken a lot of internal projects on my home network. I have found that if you go to the Amplifi advanced settings page and toggle the "Bypass DNS Cache" option to off, save and then toggle it back on devices will get the correct DNS once again.

    Makes me wonder how many other feature flags are ignored during upgrade for their default values.

  • @benjiva thanks. Will give this a try

  • Thanks @benjiva - indeed, turning off and turning on bypass DNS cache option fixes the issue and clients are now getting the right DNS server when renewing DHCP

  • Thanks for sharing, it worked. By the way: this options in not available in the App but only in the Web UI. At my place it took some minutes to have some effect.

Log in to reply