AmpliFi Alien Firmware v3.6.2

  • @cmdshft same experience here - again it’s a brief move to LTE and then back to WiFi. Less than 3.6.1 but I never had this issue with iOS devices pre 3.6.1

    Other than that better speeds and much better stability to my Nest cams including faster connection.

  • This post is deleted!

  • Anyone else experiencing slower internet performance after firmware upgrade? It's not noticeable but it's statistically slower in my case. I used to average upwards of 800 Mbps but now I'm averaging mid 600 Mbps...

  • @coldplay5467 I've noticed the same in Firmware 3.6.2 RC1 and when after I did a cold reset of the Alien (pull the plug) the speed was oke again. I think this is the same in 3.6.2 because it is the same firmware.
    So I would advice everyone after updating the firmware to pull the plug so the Alien does a could boot.

  • So, Hardware accelleration - I have not tried this multiple time since 3.6.1:

    When enabled, after a few hours I see my speeds slow to a crawl. Specifically, there is an issue opening and even finding pages, and I can see that name resolution is often failing or I have failed hops to any sites. This doesn’t get better until I turn acceleration off after which operations (and name resolution) goes back to normal.
    I have now tried this on 3.6.1 and 3.6.2 and I am forced to keep it off.

    My setup is 3 Alien Routers in a WIRED backhaul, connected to a 1Gb Fiber.

    What can I do or provide for support to look at it?


  • @Daniel-Osers I still do not understand what it really does. On my other systems it was obvious and even required to get 1gig speeds. I just don't see a difference with it on, but router speed test also doesn't work as its pointing to the wrong site and only gets 467 megs on a 1gig line.

  • @newfubq I hear you. And when I have/had it on (before the issues start) I don't see any perceived speed improvement or downgrade. But it sure makes my otherwise stable network unstable after a few hours...

  • @Daniel-Osers yeah I leave it off until someone explains what it does.

  • Hi @Daniel-Osers & @newfubq - if you accept that the Alien is based on the Qualcomm Networking Pro 1200 Platform the product brief mentions...
    Powerful networking acceleration - Programmable network acceleration and 5 Gbps in line crypto for complex and secure data transfer with Wi-Fi driver offload while offloading CPU compute. Advanced network interfaces for 10GbE WAN and LAN , as well as 5G CPE to deliver fixed wireless access.

    Only some of those capabilities would apply to the Alien
    I have it enabled under 3 different modes (DHCP, Bridge & PPPoE) and see no difference in throughput or latency, but temps did seem to come down slightly in less than scientific observations so I have just left it enabled

    But I only have single Alien site installs
    From the overall comments it feels like a lot of chatter can be associated with meshed Aliens

  • @Derek-Saville Hmmmm, maybe I'll enable and monitor Temps. Stay tuned. I've been watching my Temps almost ocd like since I received my 2 units so I have a good baseline

  • @Derek-Saville Thanks @Derek-Saville ! And, interesting!

    FYI, I had asked L1 support some time ago (their answer was "It helps improve the wired speeds from the LAN ports of Alien. You can log in to the WebUI and enable "hardware acceleration" it helps offload the CPU usage of Alien.").

    In my case I am just not sure what's happening, but it's 100% replicable after a few hours to 1 day, and only fixed by turning it back off. I even checked if maybe channels were changing and something else was affecting it, but no. It's also not a pure speed issue but affecting data flow and name resolution which is super odd (i.e. Wikipedia would take 30 seconds to load).

    I'll leave it off, obviously my only option right now ;). As a sidetone - I wonder if there is an issue with it due to my wired backhaul. The feature turns off and on, but it's not clear if it does it on all routers or just the main (since it can't be configured per unit). If all, maybe the implementation doesn't play well with the backhaul... but I'm fishing.
    BTW, temps: same: no diff with it on or off for me

  • Hi @Daniel-Osers & @newfubq - I have a considerable amount of continuous Teleport router-to-router activity between multiple Alien locations so that could also influence the temps and the effects of enabling hardware acceleration

  • @Daniel-Osers Just some quick testing with HA on and off. With HA on, on a wired connection, clean reboot of router and PC, I was getting 100mbs LESS than with acceleration OFF. I repeated the test using multiple tests same and different sites. It would always ~100mbs less with HA ON. I'll test lan to lan port another day but for internet speeds, HA on was worse.

  • @newfubq very interesting indeed. It'd be great for an official statement of what the setting does on Alien versus what it seems to be doing 😉

  • @Daniel-Osers I wonder if it’s just Hardware NAT, in the end.

  • Hi @habbasi - it can be enabled while in Bridge mode which has no NAT activity, so unless that is a UI error, it would be appear to be more inline with what Qualcomm describes from a high level

  • Updated 3.6.2, directly from 3.6.0
    Everything works fine, 30 connected device, included 3 apple units.
    Alien alone, without mesh unit.

  • Been running 3.6.2 for a week now without any issues, and I was one of those that had severe issues with 5GHz roaming handovers in 3.6.1.

    I think I might also have been the one starting the confusion that this was solely on Apple devices, but that’s a completely different issue that I’ve had since 3.5.1 or 3.5.2, where some Apple devices from around 2017 started dropping connection on non-DFS 5GHz channels, and even there I’m not sure wether it’s the Apple in the equation that’s the problem or if they share some WiFi components that would have the same issue in any product 😉 I just don’t have anything to compare with. Also, it’s very likely on some interference in the area and not primarily on the Aliens since I have seen other issues with 5Ghz connections before, including a competing brand’s mesh solution that was unable to keep a dedicated 5GHz backhaul….

    Anyhow, 3.6.2 is all good for me 🙂

  • @whaleman Interesting (once again) - I do have problems with Apple devices and 3.6.2 (in a way I did NOT have with 3.6.0 and I don't recall with 3.6.1).
    On 3.6.2. Apple devices regularly drop of wifi and then reconnect again 20 seconds or so later.
    iPhone 13Pro (Wifi6), as well as Homepod (not mini) and others. Pretty frustrating. Macs (M1 or Intel) so far have been stable.

    .k, .v. IGMP all on (.r off), and so is band steering. 56 devices total, 3 routers (wired backhaul)

  • @Daniel-Osers Sounds like a completely different issue than mine, but it doesn't hurt to test my workaround. Enabling DFS Channels (using channel 100, 80MHz bandwidth) once I got 3.6.0 solved it, but it only affected two or three devices in a household with..... 12 or so Apple devices. HomePod and AppleTVs worked just fine as well as all Macs, just some iOS devices from around 2017 were affected.

    Reverting to 3.4.3 solved it too, but I prefer using the DFS solution as channel 100 and up are allowed higher power in this region, so I get a 1400-1600MBit wireless backhaul between the units 🙂 (2 routers).

Log in to reply