Firmware update caps 300mb connection to 10 mb, team is not sending me old formware file.


  • I have already tried rolling back the firmware to 3.6.1, I've tried several factory resets, I've tried everything as per support.
    On the support page, explicitly states that if you need a firmware version older than one rollback, you are to contact support and they will give it to you. I have had a ticket open for 2 days and support is refusing to send me 3.6.0 or earlier.
    Can someone please help? Does anyone know where I can get an old bin file?


  • @magz17 Hello thank you for your patience, we are working on support cases as fast as possible.
    We have such a mechanism in place to avoid bricked units because of incompatible firmware and hardware combinations.
    Your ticket will be addressed soon.


  • Hey and thanks for the speedy reply. I just would like to point out that it says on the support page that if I want an older firmware file I can contact support for one. Regardless of whether or not the firmware is actually the problem, I would like to try using an older firmware version to test it, as I haven't touched my amplifi HD and it's been perfectly functional since I've installed it. It wasn't working after the update and I would like to rule out a defective hardware unit by first seeing if an older firmware version works. This is a legacy amplifi HD, it was among the first produced.


Log in to reply