Repeated issue with firmware updates possibly solved!


  • So i've had the same issue routinely with firmware updates in the past and have posted here previously about my issues, but just last week have possibly solved it thanks to a random suggestion on Reddit.

    Every firmware update (and at other random times) I lose all wired connections, and struggle to get everything back online. usually cycle through multiple rollbacks, unplugging/replugging everything, rebooting gigabit switch etc, and eventually, through no consistent configuration or process, get everything back online... for a while.

    But it turns out that the issue (and therefore solution) could be super simple. I have had a Satechi usb-c hub attached by ethernet cable BUT ALSO power supply sitting on my desk, which I use when plugging in my work laptop at home.

    And it turns out that there is an issue, not just for amplifi, but most routers, where an idle but powered external usb-c hub can stop the switch and anything attached from remaining connected, resulting it everything ultimately dropping off. This seems to be a problem with a lot of different usb-c adaptors too.

    So I removed the hub from the ethernet network, and everything started working fine. And is still working fine! So, I do think i've resolved a nearly 2 year long issue! I don't know how I never arrived at this detail previously, and it's never come up here, so I thought I'd just share in case it helps.


Log in to reply