Sluggish Alien


  • First off, not really sure that this post goes here but it is meant as a fix for other users experiencing this. Disclaimer: haven’t read through all postings in all forums so it could have been covered before.

    So, case is that after the first firmware was released including the “hardware acceleration” my Alien (router) felt very sluggish (I have it enabled but had no clue that it actually did not improve system performance…). I didn’t do much about it as it felt very inconsistent. But the other day I had massive problems running a Teams meeting in my gigabit connection. I tried logging on using the AMPLIFI app and the connection took forever to complete. Ran a connection speed test that showed a miserable connection. I thought that a reboot might help - it did - and in a massive way. All was great or so I thought because the next day it was the same. Nearly impossible to login, loading device list timed out and Wi-Fi connection was crappy to say the least.

    I had to try something and what I tried was to disable “hardware acceleration” and reboot - and even after a day the connection was still great. It could be a coincidence, it could be relevant- I will leave it up to you to judge 👍

    I hope this post helps others who had given up slightly on their Alien.


  • @kthuno Not a coincidence - there is something 'wrong' with hardware acceleration. With it enabled, I lose all workable connectivity after a few hours. Had to turn off which results in reliable connections and speed (with it on, I sometimes was unable to resolve to any sites).
    I think it's been removed from .3 rc, another sign of it not working as intended.


Log in to reply