Wifi not as fast as I think it should be.


  • Hi ye. I only recently purchased the Alien. I have a 1gb Fibre connection and when doing a speed test on the Alien I get between 750mb and 920mb speeds. The thing is I dont seem to get even half that over wifi. Even when connected to 5ghz on an iPhone 13 Pro Max and standing right beside it the max I get would be 300mb download. It was maxing out at around 150mb before a restart. Is there anything I can do to improve this? Thanks a mill


  • @Richie-Hatch Is the iPhone showing a Wi-Fi 6 symbol next to it in the AmpliFi app? The AmpliFi app can also run a test to verify both the connection speed and the device-to-Alien speed. I just checked mine and my iPad seems to be connecting at ~742Mbps down/~620Mbps up relatively close to the Alien, so you should definitely be able to pull more. I doubt it’s a WAN-to-LAN problem, although I don’t have the connection speed to test maxing it out.

    Might also be worth submitting a help request with your support information file for them to assist and offer guidance.


  • Hi ye. Thanks for the quick reply. Yeah the iPhone is showing with a wifi 6 symbol. How do you run the device to alien test? Cant see it in the AmpliFi app??


  • @Richie-Hatch If you go to the Performance tab and tap “Start Test”, I believe it runs both an internet speed test and the local speed test too automatically.

    The results screen should give you both results.


  • @dwightpro Ahhhh yes. I see that now. When standing right beside it i get around 450mb download on the iPhone. Also tried with my MacBook Pro M1 Max and it gets 250mb download literally right beside it too. Strange!!!!


  • @Richie-Hatch Odd! Might be worth playing with the channels on the rare chance you’re dealing with interference and making sure the 5GHz radio is using at least 80Mhz channels in the Wireless -> Advanced settings. I also run with the additional 5GHz radio off. I think those should be configured like that out of box though.

    If it still doesn’t improve, then I’d reach out to support with the support information file to see if they can identify anything that might be causing it. They are usually pretty good at offering troubleshooting steps, and they can escalate to another tier of support to go more in-depth to figure things out.


  • @Richie-Hatch Hi, could you please add more details about your surroundings. Do you have multiple WiFi routers nearby, like in a multi-story building?
    Additionally, you can enable DFS channels, set bandwidth for 80Mhz, and set channel selection to automatic. This way the router will perform scanning and choose the least crowded channel.


  • @UI-AmpliFi Hi. I live in a detached house in the countryside so don't have a lot of other wifi networks close by. I have 2 TP Link power line range adapters (with dual bank wifi - AC1350 I think!) but these are at the extremities of my house. Could they be causing an issue? I will try turning them off tonight when i get home from work.

    I have enabled DFS channels and have set the bandwidth for 80mhz.

    Thanks again

    Richie


Log in to reply