Apple M1 Chip & Audio-Video Conferencing on the Alien


  • Hi, all - looking to poll the audience before pursuing this as a bug with Ubiquity. I've spent the majority of the week tracking down a persistent issue with audio-visual conferencing on my Apple M1. Every minute, almost on a schedule, you can see the ping and latency spike causing a huge lag in any audio-visual conferencing. Below, you can see the different devices and services where I've tested this like a madman for the past week. My latest discovery has me zeroing in on the Apple M1 chip on an AmpliFi Alien - after testing on an Apple Intel chip and other various devices around the house. I've also confirmed with some of my users who have M1s and use these same services all day that they don't see this issue. I would imagine most of them don't have an Alien so I'm lumping that in with the root cause.

    It's important to note that, on the M1, this doesn't seem to affect normal streaming such as YouTube, Spotify, etc.

    In the attached picture, you can see the Google Meet data from both machines logged into the same meeting.

    Where the issue happens:

    • Alien + Apple M1 - Google Meet (audio/video), Zoom (audio/video), Slack Huddle (audio)

    Where the issue does not happen:

    • Non-Alien household Apple M1 - Google Meet, Zoom, Slack Huddle (more anecdotal but confirmed by my endusers currently on M1s)
    • Apple Intel - Google Meet, Zoom, Slack Huddle
    • Streaming content that is not conferencing software. No noticeable lag in Netflix, YouTube, Spotify from other household computers. No noticeable lag in HD streams to our fitness devices, video game consoles, etc.

    All that said, this seems directly related to an Apple M1 on an Alien system and I'm hoping there are some good suggestions here! If not, happy to file a bug with Ubiquity and see what happens. Thanks for reading!!

    0_1646415742220_Apple Alien M1.png


  • @wwsoden said in Apple M1 Chip & Audio-Video Conferencing on the Alien:

    Apple Intel - Google Meet, Zoom, Slack Huddle < Have you tested this on the Alien? Your post is unclear on this point. If so, have you compared the network configuration between the M1 and the Intel Macs? Do both DHCP from the Alien. Are they hardwired or on WiFi?


  • @mleeds by tested on the Alien, do you mean hardwired into the router? That's one of the few things I have not tried, but both laptops are connected via WiFi from the same location in the house so I'm leaning that it isn't tied directly to hardwired vs wireless.


  • Hi @wwsoden - after experiencing the issue you might want to pull a Support Info file and submit it while identifying the MAC address of the offending M1 and let AmpliFi have a look

    Have you physically moved the M1 relative to the Alien in case of some interference or if the M1 is at a threshold and it is blipping the WiFi scanning for other targets?
    Have you tried other WiFi channels?
    Or if you are running a 160MHz channel width maybe drop it down to 80Mhz as a test?
    Or if you have a North America model Alien tried setting up a custom SSID on the Additional 5Ghz radio and connected the M1 to the 5.2GHz band?


  • @wwsoden I don’t experience this at all on my M1 wired or wireless. Would however see lag spikes while my son was gaming on his Mac while wireless that went away when I wired him. So maybe there’s something there. File a bug please.


  • Hi, all - for the interested, I found the setting that seems to resolve this issue. After receiving the same latency and videoconferencing lag while hardwired into the router, I kept digging.

    After enabling Dynamic Frequency Selection (DFS) Channels setting per the recommendation of another Alien user, Google Meets and Zooms and Slack Huddles are operating normally with no lag or latency spikes.

    Hopefully this helps anyone else searching the internet for this same, oddly specific problem! Thanks!!


Log in to reply