Has This Ever Happened to You? HELP!

  • Let's say you're shopping for a stainless steel wok. So you google "stainless steel wok:
    alt text

    Then you select the Shopping tag from the Google search:
    alt text

    And when you click on one of the advertised merchandise from your google shopping search, you get the following error/nonsensical result:
    alt text

    For the life of me, I have no idea what that means. Is something wrong with my Alien wifi settings? If so, how would I go about fixing it? Please HELP!

    Thoroughly Perplexed and Annoyed

  • @Kiku-Kusanagi Do you have the ad blocker enabled in the WebUI settings? That would prevent this DNS request from being resolved properly.

  • @dwightpro I use an ad blocking app called "Wipr". I disabled the app and tried clicking on the link, but I still get the same "Unable to Connect" error message. So whatever is causing the problem isn't due to the ad blocker I am using. This happens only with most of the ads.

    I don't know whether the problem I am experiencing is inherent to the Apple Silicon Mac or the settings on my Amplifi Alien router.

  • @dwightpro The problem is a little more pervasive - I am no longer able to unsubscribe to certain emails by clicking on the "unsubscribe" link, either.

  • @Kiku-Kusanagi What’s the output when you open Terminal on your Mac and run the following command:

    dig googleadservices.com

    This command will query your DNS a server for the appropriate record. It’s result will tell you if this query is being properly answered or not.

    Being unable to click through an unsubscribe link is also indicative of some sort of ad blocker.

    You may also wish to double check your Web UI settings by following this guide: Advanced Settings in the Web UI and see if the Ad Blocker option in the Alien is disabled.

  • @dwightpro This is going to sound clueless but ... just exactly how do I access the Web UI? I have the Amplifi app on my iPhone but I don't see anything about an ad blocker in the router settings. If the Web UI is accessed only through the web browser (that'd be Safari in my case), I don't see any obvious link to the Web UI on the Amplifi website.

  • @dwightpro Here is the terminal output that you requested:

    ; <<>> DiG 9.10.6 <<>> googleadservices.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10446
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ; EDNS: version: 0, flags:; udp: 4096
    ;googleadservices.com. IN A

    googleadservices.com. 0 IN A

    ;; Query time: 56 msec
    ;; SERVER: xxx.xxx.xxx.1#53(xxx.xxx.xxx.1)
    ;; WHEN: Fri May 13 22:31:23 EDT 2022
    ;; MSG SIZE rcvd: 65

    I haven't got the faintest idea what any of that means.

  • @Kiku-Kusanagi Thanks!

    That output indicates that the DNS request for that site is being resolved to an invalid IP address (e.g. behaviour of some sort of ad blocking service). I would say that it is the AmpliFi ad blocker; however, I'm not sure how it would've become activated since you've never accessed the Web UI. You can see a successful query (what should be happening) by comparing it to this command:

    dig googleadservices.com @

    This command runs the same dig query, but it uses Quad9's DNS server ( If that resolves properly (i.e. you see an actual IP address in the "ANSWER SECTION", then the issue lies with the DNS server.

    It's worth checking the Ad Blocker option anyway. You can access it at http://amplifi.lan or the IP address of your router (in your case, it's The password is the same as you use for the AmpliFi app on your iPhone.

  • @dwightpro Thanks to your help, I am now able to access the Web UI. And under the Advanced Setting, there is a check mark next to the Ad blocker option. I experimented with this option and found out that you are right - it was the source of the problem I was experiencing earlier. Thank you so much!

    Just curious ... are there any downsides to disabling this option?

  • @Kiku-Kusanagi Excellent! Glad you got it sorted. 🙂

    I believe that option is disabled by default. The "downside" would be that your AmpliFi's DNS will no longer act as an ad blocker and will just process all DNS requests as normal. As you witnessed, this means that some websites no longer function as expected because the addresses are also used to serve ads, so the Alien is blocking that entire domain as an effort to block ads.

    If you're experiencing interruptions to browsing habits (as you are), then I'd say it's better to leave it off.

Log in to reply