Firmware v2.6.0

  • AmpliFi firmware version v2.6.0 has been released.

    v2.6.0 Changelog:

    • Full gigabit speeds for wired connections (enable Hardware NAT option in mobile app)
    • Wi-Fi client compatibility improvements
    • AmpliFi mesh stability improvements
    • Improved Wi-Fi client roaming between MeshPoints
    • Added AmpliFi Teleport support
    • Added option to bypass DNS cache (enable in web UI)
    • Added fast roaming (enable 802.11 r/k/v options in web UI)
    • Fixed issues with GRE-based VPN connection over AmpliFi network
    • Guest network improvements

    Known issue: Apple Watch Series 3 loses Wi-Fi connection when 802.11r option is enabled

  • This post is deleted!

  • 342mbps download speed, Ethernet to router with Hardware NAT enabled.
    230mbps download speed, 5ghz WiFi connected to router. 100% signal.
    138mbps download speed, 5ghz WiFi connected to Mesh Point. 100% signal.
    Quite a speed drop, tested using same Apple MacBook Pro. Latest v2.6.0 firmware.

  • I’m having a bizarro problem since this update. My iPad cannot obtain an IP4 address from DHCP. And it’s just my iPad and only on my AMPLIFI network. When I connect directly into my Xfinity WiFi router, I can get an IP4 address no problem.

  • @UBNT-Chance it’s definitely something in the 2.6.0 firmware. I have another Amplifi that is still on 2.5.0 and have no issues getting an IP4 address on that router.

  • Nice work! Glad to see some of the requests addressed!

  • Perhaps we could get some explanation of what fast roaming 802.11rkv, bypass dns cache and hardware NAT does and what / why the feature is a benefit / when / when not to use it?

  • @jayson-knight - yes. And rebooted iPad. No problem on any router other than AMPLIFI on 2.6.0.

  • I have a single standalone MeshPoint HD connected to the 3rd party cable modem router over its 802.11a/n 5 GHz WiFi band - after updating to v2.6.0 the MeshPoint can no longer connect to the router
    Tried a factory reset and during the installation process the MeshPoint can no longer see my 5 GHz SSID
    In the setup network list it actually shows it picking up only a few 5 GHz SSIDs (not mine) when it should be seeing a lot of them as it is in a dense apartment complex, but still sees around 40 or so 2.4 GHz SSID's (which about right)

  • @jayson-knight that confuses me, as when i had bridge mode enabled, i didnt have the option of the hardware nat. it was disabled. so how does the nat stay active if you have bridge mode enabled?

  • I applied 2.6.0 and enabled hardware NAT. My MacBook connection (5GHz) was typically showing ~350-390Mb/s connection to my server with Iperf3. Now I am typically over 400. That is good news.

    Now to check and see if the update fixes my garage door issue. Not confident on that but hoping for the best.

  • After FW update from 2.4.3 release to 2.6.0 release

    • Mesh Base not seen at usual fixed DHCP IP. Should be 192.168.x.241, but was now 192.168.x.211.
      --> I had to reboot the EdgeRouter X SFP (v1.9.7+hotfix.4) which does serve the DHCP with static MAC/IP mapping as well as the Amplifi Mesh Base.
    • One of two Mesh Points is still stuck at FW 2.4.3, the other one is updated to 2.6.0
      --> How to manually force an FW update for the stuck Mesh Point to FW 2.6.0? No button or hint or any note to do that could be found yet.
    • Is there a way to downgrade FW of all Amplifi Mesh devices back to 2.4.3?


  • @thomas-thaler Yeah, before I upgrade to 2.6.0, I'd like to know if there is a way to go back to 2.4.3.

  • This post is deleted!

  • This one is working for me pretty well! It solved my WiFi issues I was having with the speeds being lower. They are now where I expect them to and it works with Hardware NAT on for once. Bravo!

  • The app showed 2.6.0 available for the router but not for the meshpoints, they're still at 2.4.3. Anyone figured out how to force it yet?

  • I purchased the Amplifi HD system today and the firmware upgrade took me to 2.4.3. After setting up my system I'm getting less than half of the 300mb speed from my ISP (latest speed test is at 133MB). I noticed there was the 2.6 firmware released to resolve some of the speed issues others are seeing, but my router isn't seeing the updated firmware. Would anyone know why my router wouldn't see the latest version?

  • Am I to assume that the mesh improvements will work despite them still being on v2.4.3 ?

  • I notice some users seem to have V2.5.0 , my UK HD has not been offered an update until v2.6.0. Are there separate updates for differing countries or is this linked to the beta program?

  • @tim-sparling
    The same for me. I’m in Germany and have FW 2.5.6. Also get no update displayed for 2.6.0.

Log in to reply