2.6.1 firmware No Internet Error in bridge mode message


  • Since updating to 2.6.1 firmware I get a message on the front screen of the main router saying:

    No Internet Connection
    Please contact your ISP.

    The iPhone Amplifi app shows red X's for DNS Address and Internet Connection when I hit diagnose.

    I am running the router in Bridge Mode, always have.

    Strange thing is that I do have intent connectivity and my WIFI devices seem to access w/o any problems all be it a bit slower than it was for 2.6.0.

    Anyone have any ideas.

    Tried rebooting several time. Removed the WAN connection from my router waited a minute and then re-connected.

    Error persists.

    Enjoy..
    --Bryan


  • Quick update:

    I did some testing this morning and found that this error message is related to the fact that I'm running in bridge mode. If I turn off bridge mode the error goes away. So for now this seems to be more cosmetic than actual problem. Just annoying, guess I'll just live with this until the next firmware upgrade.

    Enjoy...
    --Bryan


  • Same here. I have -with the help of support- reverted back to 2.4.3. At least it works now, though not perfect. I've always had my mobile devices briefly losing their connection briefly every half an hour or so when the router is in bridge mode. I guess that's better than no connection at all.

    I absolutely need bridge mode. Even my alarm clock relies on a server in my own network.


  • @bryan-harding Please send me support info after running your router for a few hours.

    dima@ubnt.com

    Amplifi App -> Router icon -> Support info.


  • An update: with 2.6.1., in bridge mode, even though the display shows "no internet connection" and you cannot connect to the router with your app, the amplifi is actually working! My mobile devices can access the internet and servers in my own network.


  • @mark-smeets Next time when it happens - please try connecting to Web UI (http://amplifi.lan or http://192.168.x.y (IP address of your Amplifi)) and collect support info.


  • @dmitrijs-ivanovs I can't, the app can't connect, and amplifi.lan is not responding as well. On the router a red cross is visible saying there is no internet connection. That seems to be wrong, as I do have wifi using the amplifi.

    To replicate the problem I think you only need to turn on bridge mode and wait about 1 or 2 minutes.


  • @mark-smeets
    If you have remote access enabled, please disable Wi-Fi on your mobile phone, access AmpliFi and create support info file. If successful, please send it to dima@ubnt.com. Thanks!

    Or see if AmpliFi router's IP address appears on LCD short after reboot. You can then enter that IP address in web browser (e.g. http://192.168.100.200) and create support info.


  • @ubnt-karlis I have given the amplifi address 10.0.6.3. Going there with a browser gives me 'this site can't be reached'. That's what I'm trying to tell: I can't access the amplifi. Not with the app, and not with a browser. It doesn't respond to ping, and nmap -Pn 10.0.6.3 gives nothing as well. Still, like in Bryan Hardings case, the device does seem to work. We do have wifi!

    I'm not sure where I can enable remote access? If it involves taking the device off of bridge mode it's going to be a hassle.


  • FWIW 2.6.2 firmware update didn’t fix the no internet when in bridge mode message bug.


  • @mark-smeets It is possible that your AmpliFi router is getting different IP address than 10.0.6.3 if you set up static lease for it before firmware version 2.6.0. MAC address of AmpliFi router in bridge mode has changed with firmware version 2.6.0. However I am not sure why mobile app does not find.

    To find AmpliFi router, you can try scanning your network with command "nmap -sn 10.0.6.0/24" (adjust prefix if needed) and router should have host like "AFi-R-HD-123456.lan" in results.


  • @ubnt-karlis Indeed, I used a static mapping. Here are the steps I just took:

    • did nmap -sn 10.0.6.0/24. Showed a lot of devices within my network, but nothing like AFi-R-HD<etc>
    • checked the dhcp leases on my router, it wasn't there.
    • put a paperclip in the router, and reconfigured it. We're now in non-bridged mode. Checked the mac address of the amplifi, it's still the same
    • upgraded the amplifi router and two satellites to 2.6.2
    • checked the dhcp leases on my router. The amplifi router has ip 10.0.6.3. The satellites aren't given a lease by my router, implying they got one from the amplifi router (?)
    • In the app, I turned UPnP off and bridge mode on.
    • After a couple of seconds the app reports that it can't find the amplifi router. When trying to search for it, it fails. I can no longer connect with the app.
    • I check with my mobile if I can access the music system in my own network. I can and this proves that wifi works (I wouldn't be able to with 4g, the firewall blocks the port; the music system is only accessible from within my network)
    • I try nmap again, the amplifi router is not listed. Surprisingly, the two satellites are listed. They have ips 10.0.6.119 and 10.0.6.124.
    • I try a telnet to 10.0.6.3 on port 80, this fails.

  • @mark-smeets, thanks for detailing the steps taken. Here's more you can do help us diagnose the situation:

    • Please check log files of your primary router/firewall/dhcp server. Look for 5th and 6th octet of AmpliFi router's MAC address (:55:66).
    • Can you please reset your AmpliFi router again and enable remote access to it? Then put it in bridge mode, disable Wi-Fi on your mobile phone and see if you can access AmpliFi router remotely. If successful, please create support info file and send it to me (karlis.keiris@ubnt.com).
    • Please create support info from the mesh point http://10.0.6.119//support.php.

  • @ubnt-karlis Should the mac adress have 55:66? Mine has f0:9f:c2:36:b4:f1.
    I've enabled remote access as per the howto, but no idea how to actually access the router. If I go to 10.0.6.3 (no bridge mode) the page times out. This is piece of the routers log giving a dhcp lease to the amplifi router:

    Feb 23 15:33:04 dhcpd: DHCPREQUEST for 10.0.6.3 from f0:9f:c2:36:b4:f1 via re2
    Feb 23 15:33:04 dhcpd: DHCPACK on 10.0.6.3 to f0:9f:c2:36:b4:f1 via re2

    I'll now turn on bridge mode again. On the routers logs I see this:

    Feb 23 16:05:05 dhcpd: DHCPREQUEST for 192.168.192.53 from f2:9f:c2:36:b4:f1 via re2: unknown lease 192.168.192.53.
    Feb 23 16:05:05 dhcpd: DHCPREQUEST for 192.168.192.53 from f2:9f:c2:36:b4:f1 via re2: unknown lease 192.168.192.53.
    Feb 23 16:05:07 dhcpd: DHCPREQUEST for 192.168.197.245 from 14:9f:e8:0e:f9:d5 via re2: wrong network.
    Feb 23 16:05:07 dhcpd: DHCPNAK on 192.168.197.245 to 14:9f:e8:0e:f9:d5 via re2
    Feb 23 16:05:08 dhcpd: DHCPDISCOVER from 14:9f:e8:0e:f9:d5 via re2
    Feb 23 16:05:08 dhcpd: DHCPOFFER on 10.0.6.21 to 14:9f:e8:0e:f9:d5 via re2
    Feb 23 16:05:08 dhcpd: DHCPREQUEST for 10.0.6.21 (10.0.6.1) from 14:9f:e8:0e:f9:d5 via re2
    Feb 23 16:05:08 dhcpd: DHCPACK on 10.0.6.21 to 14:9f:e8:0e:f9:d5 via re2
    Feb 23 16:05:10 dhcpd: DHCPDISCOVER from e2:9f:c2:38:bb:9e (AFi-P-HD-36BB9E) via re2
    Feb 23 16:05:10 dhcpd: DHCPREQUEST for 192.168.192.33 (192.168.192.1) from e2:9f:c2:38:bb:9e via re2: wrong network.
    Feb 23 16:05:10 dhcpd: DHCPNAK on 192.168.192.33 to e2:9f:c2:38:bb:9e via re2
    Feb 23 16:05:10 dhcpd: unexpected ICMP Echo Reply from 89.98.25.1
    Feb 23 16:05:11 dhcpd: DHCPOFFER on 10.0.6.196 to e2:9f:c2:38:bb:9e (AFi-P-HD-36BB9E) via re2
    Feb 23 16:05:11 dhcpd: DHCPDISCOVER from 30:c7:ae:33:a5:be via re2
    Feb 23 16:05:12 dhcpd: unexpected ICMP Echo Reply from 89.98.25.1

    (My WAN address is 89.98.25.104)
    Note that 10.0.6.21 is a tablet which asks for a lease and gets it. It only has wifi.

    Again, I can't access 10.0.6.3.
    The two satellites now don't appear if I do nmap -sn 10.0.6.0/24. I'll give it some time.
    Sorry, after several minutes they still don't appear. I can't access 10.0.6.119/support.php

    Don't confuse my willingness to go through these detailed steps for enthusiasm. It's frustrating.


  • @mark-smeets As can be seen from DHCP server log files, AmpliFi router in bridge mode has MAC address f2:9f:c2:36:b4:f1, please adjust DHCP lease accordingly.

    Could it be that there are two DHCP servers on your network? I am not sure where IP addresses 192.168.. come from.


  • @ubnt-karlis I owe you a big thank you and an apology for showing my frustration. You were correct, I had a second dhcp server in my network. Maybe @bryan-harding has the same problem, so I'll describe the steps I took:

    • With wireshark, filter on udp.port==68

    • from your local pc, try to get a new ip lease. For instance by plugging out and in your ethernet cable. On linux you can click on the network device and disconnect it. On windows you can probably do something similar

    • In wireshark I saw:
      32869 2405.920344534 0.0.0.0 255.255.255.255 DHCP 342 DHCP Request - Transaction ID 0x4360937
      32870 2405.921437528 10.0.6.1 10.0.6.44 DHCP 349 DHCP ACK - Transaction ID 0x4360937
      32871 2405.932925534 192.168.192.1 255.255.255.255 DHCP 292 DHCP NAK - Transaction ID 0x4360937

    • For me, that last line was the problem. My normal network is 10.0.6.x, and here was something that is handing out 192.168.192.x. I clicked this line and it gave me this information:
      Frame 32871: 292 bytes on wire (2336 bits), 292 bytes captured (2336 bits) on interface 0
      Ethernet II, Src: SamsungE_82:25:a3 (20:d5:bf:82:25:a3), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
      Destination: Broadcast (ff:ff:ff:ff:ff:ff)
      Source: SamsungE_82:25:a3 (20:d5:bf:82:25:a3)
      Type: IPv4 (0x0800)
      Internet Protocol Version 4, Src: 192.168.192.1, Dst: 255.255.255.255
      User Datagram Protocol, Src Port: 67, Dst Port: 68
      Bootstrap Protocol (NAK)
      Message type: Boot Reply (2)
      Hardware type: Ethernet (0x01)
      Hardware address length: 6
      Hops: 0
      Transaction ID: 0x04360937
      Seconds elapsed: 0
      Bootp flags: 0x0000 (Unicast)
      Client IP address: 0.0.0.0
      Your (client) IP address: 0.0.0.0
      Next server IP address: 0.0.0.0
      Relay agent IP address: 0.0.0.0
      Client MAC address: AsustekC_48:e5:3c (08:62:66:48:e5:3c)
      Client hardware address padding: 00000000000000000000
      Server host name not given
      Boot file name not given
      Magic cookie: DHCP
      Option: (53) DHCP Message Type (NAK)
      Option: (54) DHCP Server Identifier
      Option: (255) End

    • Now I had the MAC address of the "rogue" dhcp server: 20:d5:bf:82:25:a3

    • On my switch I could filter for this mac address, and this lead to outlet G46. I removed the cable from that outlet and tested again. This time no offers for 192.168.192.x, so I had found it! It turned out to be my cable providers media box. After calling a representative (three, actually) we were able to disable the dhcp server on that box. I turns out not many people have a setup like me and they hadn't encountered this problem before. I think it even solved a long standing annoyance where netflix was taking a long time to load.

    After this I turned on the amplifi, and everything was working great immediately.

    Again @ubnt-karlis, thank you.


  • Hey Mark and @UBNT-Karlis ...

    Thanks for the clue. I didn't have the same problem as you but it did get me thinking. I use IP-MAC address binding on my (Cisco) router so anything without the correct Mac address is blocked. Here is where it gets weird. I had a listing for the Amplifi main router listed in the IP-MAC table with the correct Mac address. But I decided to turn off the blocking and check for any Mac addresses not in the table. When I did this the router came up again with the same Mac address. The cool part is that it started working and it's all back to normal. Very strange but this did work. I removed the old listing and added the new one and all is well again. I forgot to check the assigned IP address but I know it was up higher in the table probably .125 and is now .127 so it looks like the latest update caused the router to pick up the wrong IP address and then it was blocked because there wasn't a match between the IP and MAC address. Interesting. This was originally the first thing I checked when the problem came up and I had and MAC address match. I forgot to confirm the IP address and that's where I went wrong.

    So if you have this problem where the router has the "No Internet message with the RED X" on your router and you use bridge mode and you use IP-MAC address binding on your router then try refreshing the entry for your router even if the MAC address looks OK.

    Enjoy...
    --Bryan


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.