New 1Gbps connection; router only lets 100Mbps


  • This post is deleted!

  • @wade-christensen Can you generate support files for me and reference this community post in the email?


  • @ubnt-brett sorry, I was using the new UNMS app and apparently it is listing the ports in reverse order for some reason (Port 4 is first and Port 0 is last). I have deleted my post to avoid confusing anyone else.


  • This post is deleted!

  • @neil-chaplin if you look in your client specs then find out the antenna configuration - if its 1x1 then this should be fine, when its 2x2 it could be double speed like 320


  • I have this issue on a brand new amplifi mesh system.. Hardwired.. swapped network cables and nic cards on the pc.. max speed 92 Mbps.. On Gigabit Fiber to my front door. Nighthawk router 900+ Mbps..


  • Same issue here, only receive 350mbps download speed on my 1gbps Comcast Xfinity service; hardwired directly to router with Cat6 cable. Running latest beta firmware, very disappointed in this system's performance!


  • @scott-mckinney Same here! I even put in bridge mode and have a EdgeX Router in front of it and same issue. real shame.


  • I too encountered this issue yesterday as I was installing my new mesh network. I have 1Gbps connection with Spectrum. Having browsed through numerous threads it seemed like a common issue.

    System Settings:

    • Spectrum 1Gbps
    • AmplifiHD FW 2.8.9 (all devices in mesh)
    • Hardwired ethernet connection to desktop

    In troubleshooting this issue I took note of the previous wireless router results from https://www.speedtest.net which were between 940Mpbs and 980Mbps. As soon as I installed the AmplifiHD mesh those same tests resulted in 500Mbps - ~600Mbps. The behavior I noticed was a large spike in speeds as the test started and then a steady drop off (700Mbps --> 500Mbps).

    Further reading seemed to indicate that I should enable Hardware NAT since the system I am testing is physically connected to the ethernet port. After enabling Hardware NAT, the tests did not improve they stayed the same. I rebooted the cable modem itself and reran tests yielding no changes. The next day I reran the same tests without any changes.

    On a whim the last device I never rebooted after making all of these changes was the AmplifiHD router. So I went into the app and issued a reboot. After the reboot I reran these same tests against the same set of test servers and the results were all back to normal. Consistent tests ranging from 940Mbps to 980Mbps.

    On my iPhone wireless speed tests are anywhere from 350Mbps to 400Mbps to these same set of test servers. Not sure if any of this will help but a reboot of the router did seem to put things back into place.


  • @ryan-hobbs a reboot and maybe hardware nat specifically?


  • @ryan-hobbs there seem to be an issue with this device and spectrum. I see the same thing on mine. It seemed to work if you only keep one Ethernet cable plugged in. Or roll back to the 2.6.3 where there isn’t that much of a speed dip.


  • @michaele I enabled Hardware NAT and eventually rebooted the AmplifiHD router. Even now my speeds are still testing at or around 940Mbps.


  • @ryan-hobbs are your speeds still consistently at 940 Mbps?


  • I'm having this type of issue as well.

    Running following on my PC:
    Broadcom NetLink Gigabit Ethernet

    Wired Directly to Amplifi Mesh Router via CAT 6 Cable

    Wired Directly to ARRIS SURFboard SB8200 DOCSIS 3.1 32x8 Cable Modem via CAT 6 Cable

    Only able to achieve 350-450 Mbps

    When I remove Amplifi Mesh Router from the configuration I'm able to achieve 900+ Mbps.

    Is there a solution for this yet. Hate paying for higher speeds and not able to utilize them due to a router that should be able to.


  • @peter-blaisdell Make sure your hardware NAT is enabled. This is a must-have for gigabit connections and I didn't see you mention that.


  • @shane-milton Yes, I have Hardware NAT enabled. I am using the new Amplifi Gamers Edition Router with this latest firmware 2.9.3. I have a 1gbps Comcast connection with Arris SB8200 cable modem. I have to consistently reboot the router daily to regain my 900+mbps download speeds via wired connections. After a few hours throughout the day, the system slows back down to around 100-300mbps. Reboot the Amplifi Router, back to 900+mbps download speeds. I am currently awaiting a new firmware to hopefully fix this issue...


  • @scott-mckinney I have the same issue. A quicker fix is to simply unplug the WAN cable and plug it back in. The renegotiation process fixes the speeds (temporarily) . Being that this issue has been around since the release of hardware NAT for months now with multiple trouble tickets and not even a BETA firmware, I am doubtful they can fix this. Wondering if its not a hardware problem and not software.


  • @scott-mckinney I'm in the same situation; 1gb into modem; checked and see 970mbps. The best speed I've seen on a wired connection is 550mbps download and that degrades to 350mbps over the day. I've purchased a 4 port Ethernet switch and will take a direct feed from the switch to my PC, Wife's PC, Ooma, and Amplifi Router.
    Inelegant, but probably the best I do until there's an SW patch to fix the HW NAT bug.


  • @shane-sirianni said in New 1Gbps connection; router only lets 100Mbps:

    since the release of hardware NAT for months now with multiple trouble tickets and not even a BETA firmware, I am doubtful they can fix this. Wondering if its not a hardware problem and not software.

    Thanks for the tip... I'll have to use this instead of rebooting the system.


  • @tristan-baptist Have you attempted running the AmpliFi in bridged mode?


Log in to reply