Achieve Marketed Gigabit Speeds in Router Mode

  • This issue is largely undocumented by Ubiquiti support, and very few staff (when using the support app) seem to be aware of the issue.

    The long and short: You will rarely get over 500Gbps on a fiber connection when not in Bridged Mode using this router. This router is marketed as being able to, and that's a bit unethical but hardly the main problem.

    The research: multiple deleted support threads (here, and those archived on Reddit) have seemed to point to a hardware NAT compatibility conflict where most ISP's run filter partial packets, and also pass them over IPV6, which this router doesn't support unless in Bridge Mode.

    The solution as it stands: Use Bridged Mode, and negate having all the other features that make this package worthwhile (reports, Guest Mode, deactivating nodes, setting scheduled access, etc), or Use DHCP Mode, and lose half of the bandwidth you pay for every month from Verizon, AT&T, Charter, Comcast, etc.

    The real solution: PUBLICLY ACKNOWLEDGE AN ISSUE WITH LOWER SPEEDS WHEN NOT BRIDGED. Provide a fix, or release a new product that doesn't have the problem (that of course we as "beta testers", should have a discount on, or free of charge). NOTIFY PUBLICLY that the issue has been addressed, and enjoy a magnitude of positive word of mouth!


    -Customer of Amplifi HD since April, 2017

    (and please don't bother deleting this thread, as it's already been copied to multiple locations).

  • I have a similar issue with my primary Peplink router which is near business class in specs. Confirmed by engineers here:

    In looking around at different routers I've come to the conclusion that is difficult if not impossible to find a single router that provides all the features I want while simultaneously sustaining near 1 Gbps speeds. Also, for complex reasons it seems some routers perform better with different LAN connected client/OS/hardware types than others.

  • @tobias-swan Why would they claim what you're asking if it isn't true? I have a fiber AT&T connection (1gb) and can get up/down speeds around 900Mbps. Do you realize you have to turn on the Hardware NAT feature (recently added)? That enables the router speeds beyond 500Mbps.

    Here is a result I just now ran:


  • @david-miller - would you mind sharing your setup/configuration? I also have AT&T fiber but using Amplifi in bridge mode. My home is not wired, so using multiple HDs to provide expanded coverage + ethernet for equipment that does not have built in wi-fi (or has 2.4 Ghz). Thanks!

  • @rakesh-gupta My set up is pretty simple: AT&T fiber modem plugged straight into AmpliFi HD, the PC from which I above is hard-wired into the AmpliFi HD, I am not running AmpliFi HD in bridge-mode.

    I have 2 Synology DiskStations hard-wired into the router along with a hard-wired webcam. There are another 29 wireless devices attached via the router/mesh point. If you want to truly see the details of what I'm running, look for my detailed post in the Introduction forums section.

    If I haven't answered your question(s), let me know!

  • @david-miller Thanks. Two questions - 1) Are you seeing any downside of Double NAT? I can't turn off routing functions on my AT&T modem as there is other AT&T equipment connected to it (TV services) 2) On the HD - do you have Hardware NAT turned on? Any issues with that?

  • @rakesh-gupta There is no double NAT, my AT&T fiber modem is in bridge mode. The only thing plugged into my AT&T modem is the AmpliFi router.

    Yes, I have Hardware NAT turned on and the only issue is that it makes me giddy happy when I see almost hit 1000Mbps. 😉

  • @david-miller "Why would they claim what you're asking if it isn't true?"

    Because this has been an ongoing issue for the better part of a year, and you only get those speeds when in bridged mode (which I've been personally testing off and on until about a week ago).

    "Do you realize you have to turn on the Hardware NAT feature (recently added)?"

    No, I don't realize that- look at the OP that asks for CLEAR COMMUNICATION with all customers if the issue has been fixed. NONE of the threads (both deleted and active) have been updated by staff saying this is a fix.

    Even if this Hardware NAT update (which I haven't tried yet) does address the issue, this entire thread is still valid for the other points I mentioned (threads being deleted complaining about it, customers getting the run-around on updates, or not being updated at all):

    Just curious- can you post your 5GHz wireless results?

  • @tobias-swan Just to be clear, the results I tested were not in bridge mode.

    The best 5ghz speed I can find in my home is not my Pixel 2 XL but Google's Pixelbook and that can clock speeds on at around 320Mbps on 5ghz. Zip, zip, zooooooooooom.

  • I get above 320Mbps in bridged mode for wireless, but I digress...

    So after doing some more digging I read the logs:

    And here it states that Hardware NAT was supposedly addressed at version 2.6.0 (in which plenty of people, including yourself, were complaining about stability). None of the active threads ever mentioned the release notes, or that Hardware NAT came out of beta. Zero follow-up (I currently have two support cases open on this issue that's apparently resolved).

    And yes, I got from your first post that you get gigabit while running DHCP. The problem is the front page of this very website has had the same 848Mbps image for over a year before they were even available, and these speeds were only possible in bridged mode until now.

    And BTW, when you reach those speeds, they don't reflect on the HUD the way they do in the marketing- in practice, I've downloaded at a full 125MB/sec or more in bridge mode, and the highest I've caught the router display at any one time is 50Mbps, some 20x less accurate than what was actually going on.

    It's more than just the NAT fix. This should've been how it worked from the beginning.

  • @tobias-swan said in Achieve Marketed Gigabit Speeds in Router Mode:

    And here it states that Hardware NAT was supposedly addressed at version 2.6.0 (in which plenty of people, including yourself, were complaining about stability). None of the active threads ever mentioned the release notes, or that Hardware NAT came out of beta. Zero follow-up (I currently have two support cases open on this issue that's apparently resolved).

    When 2.6.0 was released, I was notified on the AmpliFi router that a new release was available. At that time, I went out to search for the release notes. It seems like an exhausting exercise to keep checking all forum threads for the mention of updates to the new release log, wouldn't it be simpler to go look when a new release is available?

    Also, in the log URL cited, the Hardware NAT option is cited.

    You are correct, there were issues (at least for me and some others) regarding dead connections. I'm not running 2.6.1 any longer, the developers put out instructions on how to request 2.6.2RC1. I did that and have been running it since Saturday morning. It seems to have largely/completely resolved the issue.

    Regarding your support case, yeah, there probably should have been communication back to you.

    It's more than just the NAT fix. This should've been how it worked from the beginning.

    I knew about the 500Mbps limit going in. I had fully researched the AmpliFi router including scores of reviews. I had also seen where AmpliFi was going to address the 1000Mbps speed issue at the start of the year. They kept their word. So, for me, there was no disappointment and AmpliFi kept their word.

  • @david-miller I scoured the web for the worst reviews on the AmplifHD before I purchased it, and the worst I found were literally cases of people that weren't smart enough to install it properly (access point links, poor site survey, etc). No review mentioned a lack of advertised speeds in my time before purchase 12 months ago.

    That being said, the 2.6.1 and subsequent updates did fix my issue- temporarily.

    Now for some weird reason, my upload speeds on ethernet have gone down from 943Mbps to 34Mbps around a week ago.

    I'm hoping this is some bug that will be updated in a few days, so I haven't attempted to restart the router yet or do any other troubleshooting.

  • @tobias-swan You might want to consider power-cycling the modem (and once that is up) bring up the router? Sometimes my modem just goes down the drain.

  • I’m having similar issues as some have already posted. I cannot get even remotely close to gig speeds. I am on ATT 1GB speeds and has no issue with my old Netgear modem. Connected directly to the ATT modem I get over 900d/900u symmetrical speeds.

    I contacted support because the link between the AHD and my ATT modem was showing Amber lights which means 10/100 link. My other devices are green indicating 1000 link. They suggested that I enable Harware NAT, which I saw as a fix for several posts here and over at reddit. That didn’t fix the issue. Then they had me do a hard reset. That also didn’t fix my issue. I then checked cables to make sure I was using Cat6 or higher. I am, and also swapped the cables to make sure it was not a cable.

    I sent them he support logs and then I was instructed to do an RMA. I declined because the unit was with in Best Buy’s return policy, so I got a new unit. Same results. No gig speeds no matter what I try. Latest firmware of 2.6.3.

    I can only achieve 200 down and less than 50 up.

  • Hi @dodge-viper - do you have an extra gigabit switch or something you can plug the WAN connection into to see if negotiates a full speed connection on another device?

    For a different system (not AmpliFi) I once had an issue where the modem and router just couldn't negotiate a proper link and putting a switch in-between allowed them both to communicate at full speed.

    Its not a solution, and not worth buying a switch for, but if you have an extra one handy, it might be interesting to try.

  • @derek-saville hi yes I have my Netgear EA9500 and it can negotiate gig speeds no problem.

  • Hi @dodge-viper - i believe the EA9500 has a gigabit switch, so if you were interested, you could plug the AmpliFi WAN port into one of the switched ports, see if connects at full gigabit speed, change the AmpliFi router to Bridge mode, and then see what speeds you are getting thru the AmpliFi for wired Ethernet and WiFi.

    Just an idea to double check the performance of the AmpliFi hardware.

  • @derek-saville so in bridge mode it works, but as others have stated, you lose a lot of features.

  • Hi @dodge-viper - it was only a suggestion to see if the AmpliFi router was working in general.
    It sounds like the AmpliFi may not be able to negotiate a proper gigabit link with your ATT modem.

    I can only suggest creating a support file (if you haven't already) and contacting the AmpliFi guys directly on the forum - @UBNT-Gunars , @UBNT-Karlis , @UBNT-Brett , etc. Send then a direct message and reference your posts here to see if they can determine what is wrong.

  • @Dodge-Viper: Hi! We've seen a few reports about link negotiation problems over the last few months. It's proven to be hard to nail down the cause so far. @Dmitrijs-Ivanovs: can you work with the customer here to diagnose the issue?

Log in to reply