Corporate vpn (cisco anyconnect) does not work over Aplifi network

  • I am migrating my home from a setup with Apple airport extreme to amplifi.

    Since migrating my VPN client does not seem to work any longer.

    Once I connect via VPN pings work and so do small packets, however doing operations such as connecting to hosts via ssh over the VPN break for some reason.

    This used to work just fine on my old network with Apple Airport.

    Is there a way I can fix this?

  • Just got Amplifi myself, and I'm having the same experience. It doesn't take a few hours to start though. I connect to the Amplifi WiFi, and immediately the Cisco VPN starts disconnecting and reconnecting about every 10 seconds.

    Did not happen with my prior ASUS router.

    AmpliFi any response? Any recommendations? There are others on Reddit ( with the same problem.

  • I haven't tested it with the current firmware, but I've been using my work laptop with the Anyconnect client for almost a year without issue. I don't VPN from home too often (maybe 25 times in the last year) but have never had an issue. Sorry I can't offer any help, just anecdotal evidence 😞

  • I have same issue in Amplify -->> EdgeRouter Pro relations. My standard L2TP/IPsec connection is working fine from any other location. Please, fix it ASAP, beacuse this is a very important function in nowadays. I send more information (logs, etc) to support some weak ago. Request ID: 47361

    Additional information: I think, the problem only appear on Windows 10 system. My smartphone (running with Android 7.0) able to connect to target network from behind Amplify.

  • I've been talking with AmpliFi support for a week now. What I've noticed through a lot of testing is that it's only a problem if I initiate the VPN connection when on the Guest network and via a beacon. If I initiate the VPN connection while on the main AmpliFi unit (WiFi) everything is fine. Try this though to see if you get the same results as I do.

    1.Disconnect the VPN
    2.Turn off the beacons (unplug, disconnect, however you want to)
    3.Wait for your laptop to connect to Guest Wifi through the main unit.
    4.Initiate/reconnect your Cisco VPN.
    5.Turn the beacons back on.

    At this point I've been successful for at least an hour with no problems. Haven't actually tried it all day. But it seems to continue to work even if my laptop goes through the beacons. It's only if I initiate the VPN connection through a beacon on the Guest network that the problem occurs.

  • I'am connecting with Ethernet from my PC, and the VPN doesn't working.

  • UPDATE: L2TP still not working, but the PPTP protocoll working like a charm (Windows 10 FU).

  • @Krisztián-Péter-Szabó latest beta software has a fix to VPNs based on GRE protocol. Did you try the software ?

  • @german-martinez No, I don't try the latest beta, because I dont want to be a beta tester! 😉

  • @alfred-perlstein I realize this is an old post but hopefully we can help someone else with the same problem. We are unable to connect my wife’s VPN on her work laptop but after speaking to a friend of mine who sets up networks for a living, he told me I was double Nat’ed. Still not sure what that means but he had me type in the IP address for my cable modem, log in and select NAT “bridged”mode. After that her computer connects to the corporate VPN at home. Cheers!

  • @C-Rose I'm having the same problem. I was not able to get my network to work in bridged mode as I do not have a switch or another router to provide IP addresses to the other devices within the network. I've connected my laptop hardwire to the router to eliminate wi-fi being the issue. However, CISCO AnyConnect still won't work that way either. The only way I've been able to get it to work is to BYPASS the router and connect straight into the cable modem instead. I'm a seasoned IT Technician...and I suspect the problem lies within their built-in and unmodifiable firewall within the router. Therefore, I've contacted Amplifi Support for this unresolved isssue.

Log in to reply