NAT setup if you don't want to use UPnP???


  • I have a double NAT setup (xFinity router to pfsense firewall to amplifi router in bridge mode). I'm not a big fan of enabling UPnP, I'd rather just setup port forwarding manually. What ports and protocols are used for the Teleport to get through the firewalls to the Amplifi router?


  • @david-0 By default UPnP randomizes the ports. You'll have to update your AmpliFi router and your Teleport (through the "support" page in its web portal) to the latest version first.

    Then you'll have to pair the teleport if you haven't yet (just tap the pair button on the router's screen, then accept the pair request in the app).

    Then log into your AmpliFi router's web portal and you'll see a new option to set a specific port for the Teleport. Whatever you port number you chose there will need to be forwarded for both TCP and UDP to the internal ip address of your amplifi router. You'll also want to make sure you don't have any firewall rules blocking connections on that port.

    Once done you should be good to go! The router will keep amplifi's server's updated with your public IP and the port you specified, and the Teleport will pull that info in order to make its connection from wherever it is in the world. The pairing between the teleport and your router will ensure the router will reject connection attempts on the opened port from non-paired teleports, or 3rd party attackers.


  • Thanks, I set it up this way and it appears to be working. One caveat, you can only set the Amplifi Routers Teleport port number through the web interface, NOT through the iOS app.

    Thanks!


  • Can confirm that this works like a charm. A bit clumsy to set up, but you only need to do it once.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.