Multiple Issues since updating from 2.4


  • Hey there. Since updating from 2.4 to the various 2.6 versions (currently on 2.6.2) I have a number of consistent errors:

    • My Garmin Smart Scale takes a lot longer to connect and upload. Basically I have to stand on it and have it weigh me twice for it to manage to connect and upload.
    • Both my Ring door bell and my Ring Chine are completely offline
    • Windows 10. All 3 Windows 10 devices in the home will go offline to the internet after a period of inactivity. I'm pretty sure this is when they go to sleep. What happens is when they awake the join the wireless can access everything on the local network EXCEPT the Amplifi device itself (can access everything else on the local network). If you try to bring up the Amplifi router web interface or try to go out bound to the internet you are unable to. I've tried changing all of the new advanced settings and nothing really works. It just sort of comes back by itself. Rebooting the Amplifi or the client sometimes seems to make it faster to recover but I think it's just me making myself feel better about not just standing there frustrated till it works. This behavior is consistent across different wifi adapters.
    • No mobile devices seem affected by this (iPad, 2x iPhone 6s, 2x Galaxy S7s), they all work seamlessly.

    Setup:

    • Equipment located in Australia (I know we have some slight Wifi differences)
    • Amplifi HD with 2x Mesh Points - Hardware Revision 19
    • Connectivity to the internet is. Client->Amplifi Mesh point or HD direct->Amplifi HD->Ubiquiti EdgeRouter-POE (Version10)->Netgear Cable modem in bridgemode.

    This setup was rock sold on 2.4.3, everything worked except for:

    • Asus Router running in a media bridge mode didn't seem to work for multiple devices behind it (I moved off that so untested on 2.6)
    • My S7 intermittently didn't seem to work on the wifi.

    My previous setup was a Ubiquiti Unifi-AC which was fine except for range which is what I bought this to solve.


  • I had some various connectivity issues with 2.6.2 and they all went away when I rebooted AHD again after the 2.6.2 upgrade. I don't know if this had ANYTHING to do with it but I also shut down UPnP (since I explicitly do all the port forwards anyway).


  • @simon-lawrence Please collect support info:

    Amplifi App -> Router icon -> Support info

    Send it to me: dima@ubnt.com Also, send me MAC addresses of your devices having problems (I suppose you are running Amplifi in Bridge mode).

    Meanwhile, try the following:

    1. Go to Web interface, disable 802.11r/k/v (if enabled)
    2. In Amplifi App, try switching WPA2 to WPA.

  • @dmitrijs-ivanovs Thanks for replying! Sorry for the delay in response. Have sent you all requested details.

    For your suggested works rounds:
    In regards to "1. Go to Web interface, disable 802.11r/k/v (if enabled)"
    I can turn off:
    Hardware NAT
    Bypass DNS
    802.11k
    802.11v

    I do not see an option to disable 802.11r. I'll turn off k and v and let you know if it improves, it didn't on 2.6.1 but then I don't think I've tried on 2.6.2

    In regards to "2. In Amplifi App, try switching WPA2 to WPA." I can do this but not sure there is a point as layer 2 seems to be working as I can ping the device itself but can't get out.


  • Hey all,

    In an XKCD moment in case someone else has these issues I thought I'd post the fix. Thanks to @Dmitrijs-Ivanovs for his help.

    Basically it comes down to Amplifi 2.6 not supporting the configuration I had the router in. I had both the WAN interface and the LOCAL interface on the same IP and subnet. I did this because I have my EdgeRouter doing all the tricky work on the internet side. I've now moved the WAN interface to a free routing interface on the EdgeRouter on a different address range. This has resolved all issues.

    Exactly why this only seemed to affect Windows 10 PCs I don't know.

    Anyway just incase someone else decides to have a similar crazy setup as me I thought I'd post up.

    https://xkcd.com/979/


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.