Maximum WiFi (Mbps) lower than expected.

  • Hello everyone,

    Just got 2 mesh routers yesterday and installed them as a pair via the wired ethernet backhaul solution. The system design and GUI is gorgeous to the eye but I am slightly disappointed in the maximum Mbps I get out of it.

    I have a fibre connection at home 500/500. I need to have dhcp on unfortunately. So I have set the main mesh router set to bridge mode. With my previous TP-Link router I had a similar setup and reached speeds of 500Mbps up and down.

    With this current setup It seems as if I’m being ‘capped’ to 350ish Mbps and seldomly I get lucky to around 450ish Mbps. Never managed to get close to 500Mbps.

    Strangely enough I do get a ‘network’ connection of 800-900 Mbps. I tested this with an app that measures the ‘actual’ connection speed of the client and the router (AP).

    I have verified that my client is connected to the nearest mesh router and on the 5ghz band. Tested for both mesh routers.

    I was wondering if the 5ghz channel/band is limited to a maximum speed of 450ish Mbps?

    Thanks in advance for any hints or advice

  • @remco-nl75

    Would you advise setting the mesh router back to DHCP mode and assign a different subnet /ip-range to the mesh router (outside from my ISP modem dhcp range) and DMZ the mesh router on my ISP modem?

    Would this make a difference?

  • @remco-nl75 ~450 Mbps is current practical limit of Amplifi in 5 GHz band. Wired clients with HW NAT enabled should expect full gigabit speed.

  • @dmitrijs-ivanovs

    Thank you for the quick and clear reply. I no longer need to worry on that part.

    So I guess that the current bridged mode configuration is the best option for me? However I’m not able to find HW NAT optio under the bridged mode configuration?

    I will check one more time the wired gigabit connectivity.

  • @remco-nl75 Bridge mode should be used only when you have another modem or router doing NAT for you. In all other cases, NAT mode should be used.

    In bridge mode HW NAT option cannot be used because NAT is not applicable at all.

    P.S. most casual users should leave NAT mode on in all cases.

  • Hey @dmitrijs-ivanovs - I just wanted to say "Thanks" for all of the quick/direct answers you've been providing to so many people lately. Rocks when folks like you step up to help us! Thank you. 🙂

Log in to reply

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.