Devices will not change to stronger mesh point


  • Some devices will not change to the nearest and stronger meshpoint.

    Especially when you reboot the router those devices looses the wifi signal to the meshpoint. After the Amplifi router is rebooted the first thing that this devices do is to connect directly to the Amplifi router. After a while the meshpoint will connect to the router and can offer a better signal to those devices.
    Instead of switching to the nearest and stronger meshpoint the decices will stay connected to the router, even if the signal is very low.
    I have to manualy reboot the devices in order to connect again to the strongest mesh point.

    At the moment every Yamaha Musiccast device ist affected an one TP-Link WLAN-Adapter. Other dvices like notebooks, mobile phone are routed perfectly to the strongest meshpoint or the router.
    All affected devices have only the ability to connect to the 2,4 GHz.

    This behaviour is very annoying and not as advertised from the manufacturer.

    I use the latest firmware and the option to force the connections to the router is disabled (default behaviour)


  • What I have noticed is that the signal needs to degrade to a certain point (~-70 or so) before the handoff happens. So if you are ~-65 and there is a -40 access point it might not necessarily handoff. Your mileage may vary.


  • I've noticed that after a full reboot of the router and mesh point, everything starts off connected to the router and over the course of several hours, they start moving to the mesh point. It takes time. It always happens though.


  • I believe that after a full reboot (return from a power failure) that the router starts accepting WiFi connections before all the mesh points are activated. I'm suggesting that there be a time delay (say 1-minute) AFTER all mesh points go live for the router to accept connections allowing for things to settle out (similar to a soft-start).


  • That makes logical sense. Routers have to be the first thing back on line because mesh points need to connect to that. However, I wonder, if the client device can attach to the mesh point (even without a mesh point-router connection established). Does the mesh point require a router connection in order to start accepting client connections? I can see this scenario happening. I know that my mesh antennas take longer to establish connectivity than either of the routers.


  • Partially why I want to be able to turn off the main router from broadcasting WiFi. Would rather my meshpoints handle WiFi.


  • @michael-easlick Supposedly, there is a release coming where it's an option for everything to broadcast a different SSID. With that release, you could then force a connection to the mesh point.


  • Hi @michael-easlick - do you see a "Pause Meshpoint" option for the main router in the app?
    This is supposed to turn off just the WiFi of that device and leave the other Meshpoints ones still handling WiFi.


  • @derek-saville no pause for the main router. It's just in a weird spot, would be nice to pause it.

    Although I can understand why it isn't allowed yet. Maybe if there is another meshrouter with wired backbone then allow it?


  • @david-miller yeah that might be the only option.

    Really it's just that I have 3 MeshRouters (2 as meshpoints) and a ranch style house. Router is in the middle, in the basement and I'd rather use one on each side of the house.

    I get -42 in rooms from two of them and it causes the devices to act strange.


  • @michael-easlick - yes, if you don't have wired backhaul then you would need a separate (hidden?) dedicated wireless backhaul in order to 'pause' the main router.
    Maybe @UBNT-Gunars can comment on if they plan to implement something like that with the upcoming SSID features...


  • Hi Giuseppe! In the latest firmware and app you should be able to create a custom SSID on a specific mesh point. It ensures that your device always connects to the same network node and uses the same band.


  • @giuseppe-costa In Wi-Fi technology, client devices select stronger or better AP themselves. We have very limited options to influence it from AP side. Usually devices start searching for another candidate AP when signal level from current AP becomes too low. Scan procedure is essentially less reliable in 2.4 GHz band because of typically higher noise levels. For this reason, your 2.4 GHz devices might not find another candidate AP at first or even second attempt. We have seen environments where even in 5 GHz band it takes 4-5 scan attempts to find a good candidate for roaming.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.