Teleport Very Slow To Gain Access To Internet Resources


  • FINAL UPDATE: I switched the Teleport device back over to WiFi, and it took about 15 minutes before I could access internet resources. Here are the support files. So really it looks like having a wired connection, I cannot access internet resources. Would be very curious to see what the problem is. And, the 10-15 minute latency until I can access internet resources is unacceptable. I am planning on deploying some of these to my remote workers so they can access my home network, but with these types of problems, this solution will not be feasible. I really want to get rid of my current VPN solution and just use these devices instead since they are cheap, and self-maintaining. But they need to be able to just be plugged in, connected to a network (either wired or WiFi), and be ready to go within just a couple of minutes.

    0_1526896483195_Internet Accessible Support Files.tar

    UPDATE 2: Running the speed test/connectivity tests from the Teleport WebUI completes successfully. Yet I still have no connectivity to internet resources.

    0_1526894197622_A261D3FF-87AD-4675-969D-B8E1A5CC560C.jpeg

    UPDATE: It’s now been over 30 minutes, and I still have no access to external resources. This is new behavior, and I have not changed any settings on my Amplifi network. This is via a hardwired connection at the hotel I’m staying at, and I know the Ethernet connection is hot as I can plug it directly into my laptop and get immediate access to internet resources. Obviously, this is very bad. The only changes I’ve made to my DNS servers back at the mothership was updating Windows 2016 with the latest patches on patch Tuesday. That shouldn’t have an effect though, right?

    I’ve posted about this before, and it got no hits (and I had a support ticket open but gave up on trying to get it resolved), so I’m posting again: When I plug my teleport in and connect to a network (WiFi and hardwired), it can take up to 30 minutes before I have access to internet resources. I can immediately access resources on the remote network I’m connecting to, but cannot connect to internet resources. It always takes at least 10 minutes before I can access internet resources. I’ve run a tracert, and nothing is making it past the initial hop.

    I have bypass DNS cache enabled on my router since I run my own DNS servers (with forwarders set up to 1.1.1.1 and 1.0.0.1 from Cloudflare), could this have something to do with it? The good news is once whatever happens to allow me to access internet resources, it stays on, but this is pretty annoying. I have attached the support files from my teleport while it is unable to connect to internet resources. I will update this post with another set of support files when it is able to connect to internet resources.

    0_1526891451174_Not able to connect to internet resources support files.tar


  • @jayson-knight said in Teleport Very Slow To Gain Access To Internet Resources:

    I am planning on deploying some of these to my remote workers so they can access my home network, but with these types of problems, this solution will not be feasible. I really want to get rid of my current VPN solution and just use these devices instead since they are cheap, and self-maintaining. But they need to be able to just be plugged in, connected to a network (either wired or WiFi), and be ready to go within just a couple of minutes.

    Have you considered trying running your home Teleport cubes in Bridge mode?
    So the cube is essentially only only acting as a Teleport server behind a different router.
    Separating the functions may help diagnose what is going on.

    @UBNT-Gunars previously indicated a cube is essentially balanced to serve one teleport until the kernel mode VPN update takes it to 2~3.
    But if you are planning to run multiple Teleports, you might eventually want 2 or more cubes serving them.
    It would just be nice then to be able to disable the WiFi completely on the bridge mode Teleport server cubes...😉 @UBNT-Gunars


  • @derek-saville Your post is a little confusing to me...when you say “teleport cubes” what do you mean? I have an Amplifi router at home (and might pick up one more to act as a switch via backhaul), but running it in bridge mode isn’t an option for me.

    Again I’m just not positive I know what you’re talking about, but it sounds intriguing. That being said, it looks like 2.7 is getting fairly close to RTM...2.7 is supposed to have the 2-3x kernel mode improvements, right? @UBNT-Gunars

    Please feel free to give me more details on what you’re talking about though, b/c being able to deploy these is something I really want to do to decrease my overall cost of my current VPN deployment.


  • Hi @jayson-knight - sorry for being confusing.
    During the original Teleport beta, to avoid messing around with your main router, one could install the HD Mesh Router cube that the Teleport was paired to in bridge mode behind the main router.
    The WiFi from that bridge mode Teleport cube is then essentially on it's own (and I wish its WiFi could be turned off completely).

    Everyone's setup is different and very hard to diagnose.
    The HD Mesh Routers that are paired with my Teleports are in bridge mode behind a main router and I am not seeing any of the issues that you are describing.
    So it was just a thought to try for diagnosing your problem, and I am not suggesting you should change your setup.


  • @derek-saville I’m absolutely willing to try that. Could one bridged router support multiple teleports? I didn’t realize that when you paired a teleport, you could pair it specifically to an Amplifi cube. Topologically, the bridged router would sit behind the main router, right?

    So in my case, I’m with AT&T, so I have an AT&T gateway. My topology in this setup would be:

    Internet <-> AT&T Gateway <-> Amplifi Router (non-bridged) -> Bridged Router (dedicated to teleport)

    Would I be able to use the other Ethernet ports on the bridged router as a switch? One of the Amplifi staff recommended I get a 2nd Amplifi cube to use as a switch (I’m out of ports) via backhaul instead of buying a dedicated switch.

    I don’t know if that’s making any sense, I’m a software engineer by profession and know a bit about networking, but not much from a hardware perspective.


  • Hi @jayson-knight - I think I understand what you want.
    I will do some checking when I get home and confirm again.
    But from memory everything connected to the bridged router can see everything connected to the main router.
    At least I haven't come across anything that hasn't worked yet.

    It would be great to hear from @UBNT-Gunars about the trade-offs / differences between Bridge Mode and Ethernet Backhaul Meshpoint mode.


  • Hi @Jayson-Knight - I plugged a laptop into my main router and a laptop into my bridges router and they communicate just fine.

    I wanted to double check both as wired Ethernet connections since most of my devices are wireless.

    My understanding is that a router in bridge mode is essentially a switch + independent WiFi access point.

    Keep in mind though that it will be separately managed from an app perspective from your main router!
    Which is a PITA sometimes.

    I hope to convert my main router to something like a Ubiquiti EdgeRouter in the future once UNMS is implemented for Amplifi.
    That way I can have SmartQueue or another QoS implemented for multiple Teleports behind the ER and hopefully all managed from one app.
    And the AirCubes could be better home meshpoints than using HD Routers.


  • @derek-saville Perfect, this is exactly what I wanted to hear. I still haven’t heard from anyone on another post I made asking if multiple teleports are supported, and what impact they would have on performance. Do you know the answer to this? If multiples are supported, and can be “tethered” to just the bridged cube, this will be exactly what I need to ditch my current VPN and just use these (provided they get the performance up on the teleports as promised).


  • Hi @jayson-knight - I use 2 Teleports, one for traveling and one for a fixed remote site, but I have them each paired to their own 'cubes' (actually purchased them as the pre-paired sets instead of standalone Teleports).
    I did this because the performance was borderline acceptable even with one Teleport.
    It actually took quite a while to get everything working, and I am hesitant to mess with a functional setup as AmpliFi feels 'fragile' at times - for example I can lose significant Teleport performance with just a modem or router reboot, and it can take a couple of reboots for Teleport to magically work again at their full achievable speed.
    That, and the setup is still annoying.

    But I will try to put a second Teleport on the same cube this weekend and let you know if that part at least works.
    Probably won't be able to do much speed testing though.

    If you are only going to run 2 or 3 Teleports, then you probably won't need to run a separate Router in Bridge Mode after the new kernel improvements.
    I was only suggesting trying it because you seem to have significant routing delays or issues with your Teleport and mine instantly have internet access once they connect. For example, once I have a solid blue ring I can start watching a live F1tv GP immediately.

    Note though that I am using UPnP and I am not using 1.1.1.1


  • Hi @Jayson-Knight - I moved my travel Teleport to the same router as my fixed site Teleport.
    It paired and set up in the typically annoying manner (can’t wait for the new Bluetooth interface) and is functioning normally.

    My fixed site Teleport is currently unplugged and offline, so I can’t comment on how well such a setup works when both Teleports are active.

    Will let you know once I travel again the performance impact, but I am expecting not great results until the kernel mode improvements are implemented.

    In summary though, one AmpliFi router can support at least a second paired Teleport and based on how easy it was, I am guessing it will pair even more unless they implemented a software limit.


  • Hi @Jayson-Knight - having 2 Teleports on the same router hasn't been all that great.

    First, other threads have reported problems with using 1.1.1.1.
    Have you tried changing back to 8.8.8.8 or something else to see if the internet access delay situation improves?

    The second Teleport is paired, shows up in the web interface as fine, connectivity tests are fine, and looks normal in the app.
    However, it just doesn't want to make a remote connection nicely.
    Once I select a WAN WiFi access and enter the password, it often hangs at the final HOME NETWORK check.
    I can normally create a hotspot on my iPhone and connect a Teleport, but that no longer works for the second Teleport.
    So, not sure what is going on there.
    It doesn't seem to matter if my first Teleport is online or offline.

    However, my fixed installation Teleport always connects normally and has doesn't seem to be affected by the second one at all...except for throughput when both Teleports are active.

    My primary use of Teleport at the fixed installation is for streaming online video services.
    Simultaneous streaming on both Teleports doesn't work - as soon as the second stream starts (usually after some buffering) both streams stall out and fail. I usually see streams around 2 to 2.4 Mbps, but once a second stream is active they both seem to get stuck around 500-600 Kbps and hang.

    Speed tests seem normal when only one Teleport is active.
    But two Teleports seem to trip over themselves under heavier bandwidth conditions.

    At this point I would just wait for the improvements they are working on - assuming they will be released soon.
    I am going to leave my setup like this for now and see if the kernel mode changes allow simultaneous streaming.


  • @derek-saville Yeah I’m just giving up on this for now. I use internal Windows DNS servers, with forwarders to 1.1.1.1 and 1.0.0.1. I’ll try other DNS servers and see if that works, but for now I’m just going to wait and see if the next version of the firmware updates fix this. If it doesn’t fix it, sadly, I’ll have to find a different solution (or just stick with mine). The support staff around here have been oddly silent, so hopefully that means we’re gearing up for the 2.7 RTM soon. This is pretty much the only problem holding me back from a full scale deployment of these devices at this point. I realize this is consumer equipment, but I don’t have the time (nor the money) to hire a network admin for my tiny side company I run.

    Fingers crossed that this next update is a good one.


  • Hi @jayson-knight - if you don’t mind sharing, roughly how many Teleports do you plan on using and how bandwidth intensive will their roles be?


  • @jayson-knight FYI, somebody at UBNT has told me that they're effectively "rewriting" all of the Teleport firmware. It's not just some simple fixes but some major redesigns. They mentioned things like removing the need for UPNP to be enabled, 3x faster throughput, lower overhead on the cube routers on the home network, among other things.

    At this point, given the issues you've seen, I'd suggest that you consider keeping what you have now until this rewrite is complete and then reevaluate. I know "just wait and see" isn't usually the ideal response but if you do that, you might be pleasantly surprised at how the Teleport works afterward as compared to now.

    I also get ~5 minutes of instability after setting it up before it then becomes rock solid (for days or maybe even weeks), but I'm not using it in a professional capacity - I mostly use it to plug in at a hotel when I'm traveling, and I can deal with that 5 minute delay when first setting it up and turning it on. I used it at a conference recently with a Jackery battery with an AC plug and that 5 minute delay was much more painful there, but I managed to get by with it still. I'm definitely looking for the new version of the firmware myself!


  • Hi @shane-milton - yes we have been given similar information about the new Teleport firmware including the new Bluetooth setup and kernel space VPN on the router cubes.
    They were originally targeting end of May, so hopefully they are on track, but one can imagine the difficulty in debugging such significant changes.

    @Jayson-Knight reported that once his Teleport connects (solid blue ring) he cannot access internet based sites outside his home network for about 15 minutes.

    Is that the same problem you are experiencing for about 5 minutes?

    Once my Teleport connects, I have instant access to internet based sites.


  • @shane-milton I have no problems waiting, just want to make sure they are still on track for getting this stuff in the next release. It sounds like we have the same problem though, it’s just strange that I have access to all internal resources, but can’t make external connections. I’m not a networking guru, otherwise I’d break out the toolkit to try and figure out why. I’m going to assume it’s something to do with network architecture (having my own Windows DNS servers), otherwise I’m sure there’d be a lot of complaints about this. I could even deal with just 5 minutes, but sometimes it’s like 20 mins or more.

    Thanks for the info!!!


  • @derek-saville Yes, my 5-minute period seems to be about the same thing as his 15-minute period. It's always been with a wifi-based backhaul and the sources have varied (hotel wifi, conference wifi, phone tethering). Once I figured out I just needed to let it sit and wait for a few minutes then try, life got much better.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.